summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/dump
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2017-09-12 19:52:08 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-09-13 00:23:08 +0300
commitc9fe4cb40e025998a7b90743b29f31b3eaf0d821 (patch)
treecda880bf778a9da3daafdadac1448d3e0522849b /meta-phosphor/common/recipes-phosphor/dump
parent37c820cf236bc8343a8b839c461ec15fcee6373d (diff)
downloadopenbmc-c9fe4cb40e025998a7b90743b29f31b3eaf0d821.tar.xz
phosphor-debug-collector: Create /var/lib/systemd/coredump mount point
Mount /var/lib/systemd/coredump as a tmpfs to be used as a file location for systemd-coredump generated core dumps. Proposed fix is a workarround for core file missing in the BMC dump. Core manager watches for inotify event IN_CLOSE_WRITE on core file to initiate application core type BMC dump. ubfi based core path triggers incorrect inotify events, which eventually fails to collect actual core file. Resolves openbmc/openbmc#2240 Change-Id: Ia70ea7ea34a05596e5609efca880887884a78387 Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/dump')
-rw-r--r--meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb5
-rw-r--r--meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/obmc-dump-monitor.service2
-rw-r--r--meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/var-lib-systemd-coredump.mount7
3 files changed, 13 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
index f6c098e1e..7be45ec1b 100644
--- a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
+++ b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
@@ -64,7 +64,10 @@ FILES_${PN}-monitor += "${sbindir}/phosphor-dump-monitor"
FILES_${PN}-dreport += "${bindir}/dreport"
DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
-SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
+SYSTEMD_SERVICE_${PN}-monitor += " \
+ obmc-dump-monitor.service \
+ var-lib-systemd-coredump.mount \
+"
EXTRA_OECONF = "BMC_DUMP_PATH=${bmc_dump_path}"
diff --git a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/obmc-dump-monitor.service b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/obmc-dump-monitor.service
index 0e8ef3b5d..0af6cea9d 100644
--- a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/obmc-dump-monitor.service
+++ b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/obmc-dump-monitor.service
@@ -1,5 +1,7 @@
[Unit]
Description=Phosphor Dump core monitor.
+Wants=var-lib-systemd-coredump.mount
+Before=var-lib-systemd-coredump.mount
[Service]
ExecStart=/usr/bin/env phosphor-dump-monitor
diff --git a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/var-lib-systemd-coredump.mount b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/var-lib-systemd-coredump.mount
new file mode 100644
index 000000000..66d0e4fbc
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector/var-lib-systemd-coredump.mount
@@ -0,0 +1,7 @@
+[Unit]
+Description=/var/lib/systemd/coredump
+
+[Mount]
+What=tmpfs
+Where=/var/lib/systemd/coredump
+Type=tmpfs