summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/inventory
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-06-20 22:39:40 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-06-21 08:39:49 +0300
commit569ed9cc84319851cc4638e3464e155b6d1773b4 (patch)
treee90d5d58ccccb3a7ce6f4d96ae2b2e7ac15f16d8 /meta-phosphor/common/recipes-phosphor/inventory
parent1d49321e8993cdfdc0091069b5072278fa0a0ab0 (diff)
downloadopenbmc-569ed9cc84319851cc4638e3464e155b6d1773b4.tar.xz
inventory: Remove sample object
Replace the example yaml with an empty configuration by default. Rename OBMC_INVENTORY_PROVIDERS to PHOSPHOR_INVENTORY_MANAGER_CONFIGS since this variable does not define structure. Change-Id: I2d64bb21029ac433c018ba6258c1f11dcd0ff002 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/inventory')
-rw-r--r--meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb18
-rw-r--r--meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb6
2 files changed, 3 insertions, 21 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
deleted file mode 100644
index e59bc881a..000000000
--- a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Managed inventory with Phosphor inventory manager - example"
-PR = "r1"
-
-inherit native
-inherit phosphor-inventory-manager
-
-require phosphor-inventory-manager.inc
-
-S = "${WORKDIR}/git"
-
-do_install() {
- SRC=${S}/example
- DEST=${D}${base_datadir}
-
- for f in `find $SRC -type f -printf "%P\n"`; do
- install -D ${SRC}/$f ${DEST}/$f
- done
-}
diff --git a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb
index 137733621..bc65eec18 100644
--- a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bb
@@ -7,9 +7,9 @@ PR = "r1"
inherit obmc-phosphor-license
inherit native
-OBMC_INVENTORY_PROVIDERS ??= "phosphor-inventory-manager-config-example-native"
+PHOSPHOR_INVENTORY_MANAGER_CONFIGS ??= ""
# To add additional managed inventory items, create a recipe in your layer,
-# and add it to OBMC_INVENTORY_PROVIDERS with a bbappend to this recipe.
+# and add it to PHOSPHOR_INVENTORY_MANAGER_CONFIGS with a bbappend to this recipe.
-DEPENDS += "${OBMC_INVENTORY_PROVIDERS}"
+DEPENDS += "${PHOSPHOR_INVENTORY_MANAGER_CONFIGS}"