summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/ipmi
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-15 05:55:54 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-21 18:28:03 +0300
commit4851f4193b61e6adfb5a2f9b59871002121de2be (patch)
treec6d6e82745351969f980f7e44d0756053d1d0d5f /meta-phosphor/common/recipes-phosphor/ipmi
parentf99ffdd964f83d4a976e6659f8902ecd8adff332 (diff)
downloadopenbmc-4851f4193b61e6adfb5a2f9b59871002121de2be.tar.xz
ipmi: Move ipmi sensor config recipe
The sensor config recipe is a native recipe. Native recipes do not build packages and therefore cannot be a packagegroup. Do not inherit packagegroup and remove references to variables without meaning in native context like PACKAGES. Rename the recipe to reflect its status as a native recipe. Move the recipe to the ipmi namespace since it isn't a packagegroup. Fix up the associated bbappend in the OpenPower layer. This eliminates a number of "manifest-foo:populate_sysroot not found" build warnings. Change-Id: Id56896efaa7e11a2427047d896ee36e69139de31 Tested: Built a witherspoon image Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bb9
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb2
2 files changed, 10 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bb
new file mode 100644
index 000000000..7fe9ae3da
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bb
@@ -0,0 +1,9 @@
+SUMMARY = "OpenBMC - IPMI sensors"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+OBMC_IPMI_SENSORS_PROVIDERS = "phosphor-ipmi-sensor-inventory-mrw-config-native"
+
+DEPENDS_append = " ${OBMC_IPMI_SENSORS_PROVIDERS} "
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
index 67c6996db..9c846a548 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-inventory-mrw-native.bb
@@ -10,7 +10,7 @@ inherit mrw-xml
DEPENDS += " \
mrw-native \
mrw-perl-tools-native \
- packagegroup-obmc-ipmi-sensors \
+ phosphor-ipmi-sensor-config-native \
phosphor-ipmi-sensor-inventory-mrw-config-native \
"