summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/packagegroups
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-27 06:11:36 +0300
committerAndrew Geissler <geissonator@yahoo.com>2018-02-08 21:16:01 +0300
commit01e6b17936d00bcb0d3547873c557732abff1b80 (patch)
tree8a8c1fcd48282d3dad78d67d2ce20d97f6e83e2f /meta-phosphor/common/recipes-phosphor/packagegroups
parenteff3d02a180ef60102f1f25d765b2ddf72831be3 (diff)
downloadopenbmc-01e6b17936d00bcb0d3547873c557732abff1b80.tar.xz
ipmi: Refactor whitelist generation
The current dual-use of packagegroup-ipmid-providers as a dependency insertion point for both native (whitelists) and runtime (provider libs) doesn't work under Yocto 2.3. Move the ipmi provider configuration from recipe scope to the global configuration scope so we can continue to avoid dually maintaining whitelist and provider lists _and_ build under Yocto 2.3. Also rename OBMC_IPMID_PROVIDERS with the more conventional VIRTUAL-RUNTIME_phosphor-ipmi-providers. Change-Id: I1acce0b08047cba2312f60542942cccbcff66aec Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/packagegroups')
-rw-r--r--meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
index 87d17f967..cbe7e7fb9 100644
--- a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
+++ b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
@@ -7,12 +7,5 @@ inherit obmc-phosphor-license
PROVIDES = "${PACKAGES}"
PACKAGES = "${PN}-libs"
-OBMC_IPMID_PROVIDERS = "phosphor-ipmi-fru"
-
SUMMARY_${PN}-libs = "Extra providers for ipmid."
-RDEPENDS_${PN}-libs = "${OBMC_IPMID_PROVIDERS}"
-
-WHITELIST_FORMAT = "{0}-whitelist-native"
-OBMC_IPMID_WHITELISTS = "${@compose_list(d, 'WHITELIST_FORMAT', 'OBMC_IPMID_PROVIDERS')}"
-
-DEPENDS_append = "${OBMC_IPMID_WHITELISTS}"
+RDEPENDS_${PN}-libs = "${VIRTUAL-RUNTIME_phosphor-ipmi-providers}"