summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2018-03-13 21:46:27 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-15 17:23:57 +0300
commit6bc2f026595b69c9594ce4843502a98129351143 (patch)
tree9a3364f618c88b080207a92a40362dbbc1430715 /meta-phosphor/common/recipes-phosphor
parentd7bf8c17eca8f8c89898a7794462c773c449e983 (diff)
downloadopenbmc-6bc2f026595b69c9594ce4843502a98129351143.tar.xz
Make host-check a part of host state function
In the previous review it was noted that it didn't make much sense for host-check to be it's own provided function in OpenBMC. It's more of a recommended piece of the base host state function. Change-Id: I024472e96ea00f411e8348e0221c210f84700019 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb5
-rw-r--r--meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb10
2 files changed, 7 insertions, 8 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index ee6e13cb0..41eb7a3f7 100644
--- a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -35,11 +35,6 @@ RDEPENDS_${PN}-chassis-state-mgmt = " \
${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
"
-SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset"
-RDEPENDS_${PN}-host-check-mgmt = " \
- ${VIRTUAL-RUNTIME_obmc-host-check} \
- "
-
SUMMARY_${PN}-extras = "Extra features"
RDEPENDS_${PN}-extras = " \
phosphor-rest \
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
index 672090e15..67988f538 100644
--- a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
@@ -25,10 +25,14 @@ DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
SYSTEMD_PACKAGES = "${PN}-discover \
${PN}-reset-sensor-states \
"
+
+# The host-check function will check if the host is running
+# after a BMC reset.
# The reset-sensor-states function will reset the host
-# sensors on a BMC reset or system power loss so it is
-# recommended when bringing in the host state function
-RRECOMMENDS_${PN}-host = "${PN}-reset-sensor-states"
+# sensors on a BMC reset or system power loss.
+# Neither is required for host state function but are
+# recommended to deal properly with these reset scenarios.
+RRECOMMENDS_${PN}-host = "${PN}-host-check ${PN}-reset-sensor-states"
inherit autotools pkgconfig
inherit obmc-phosphor-dbus-service