summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-09 06:29:25 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-13 05:51:06 +0300
commitb81d4282120dc0c19e0f73833e12a9a5baa7a3a5 (patch)
treed33cc40d5b2395efc9992026440c50d1d4c74026 /meta-phosphor/common/recipes-phosphor
parent3f94605e3a2ba3b89a8a4a8d3ee8946c15ec7b85 (diff)
downloadopenbmc-b81d4282120dc0c19e0f73833e12a9a5baa7a3a5.tar.xz
Remove obmc-mrw machine feature
Using MRW or not is distro policy. As such remove the obmc-mrw machine feature. Do not enable the remaining obmc-mrw distro feature in the base phosphor distro configuration. Create new distro configs for the systems that use MRW today (i.e. Witherspoon) that enables the obmc-mrw distro feature and point the local.conf.sample at the new distro configuration. Change-Id: If4cedc745b3ee942518fbfd4d5cf2cd5b60f346d Tested: Built a Witherspoon image and validate the manifest Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-manager.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb
index ef1403096..920f63745 100644
--- a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config-mrw-native.bb
@@ -11,7 +11,7 @@ DEPENDS += "mrw-native mrw-perl-tools-native"
# Generate a YAML files based on MRW input
do_install_append() {
- USE_MRW="${@cf_enabled(d, 'obmc-mrw', 'yes')}"
+ USE_MRW="${@df_enabled(d, 'obmc-mrw', 'yes')}"
DEST=${D}${datadir}/phosphor-led-manager
if [ "${USE_MRW}" = "yes" ]; then
diff --git a/meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-manager.bb b/meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-manager.bb
index 17f727af5..a63a1f24a 100644
--- a/meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/settings/phosphor-settings-manager.bb
@@ -16,7 +16,7 @@ DEPENDS += "python-pyyaml-native"
DEPENDS += "python-mako-native"
DEPENDS += "autoconf-archive-native"
DEPENDS += "virtual/phosphor-settings-defaults"
-DEPENDS += "${@cf_enabled(d, 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native')}"
+DEPENDS += "${@df_enabled(d, 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native')}"
DEPENDS += "sdbusplus sdbusplus-native"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "phosphor-logging"
@@ -48,7 +48,7 @@ python do_merge_settings () {
cmd.append(os.path.join(workdir, 'merge_settings.py'))
cmd.append(os.path.join(settingsdir, 'defaults.yaml'))
# Used for any settings from the MRW
- use_mrw = cf_enabled(d, 'obmc-mrw', 'true')
+ use_mrw = df_enabled(d, 'obmc-mrw', 'true')
if (use_mrw == 'true'):
cmd.append(os.path.join(settingsdir, 'mrw-settings.override.yaml'))