summaryrefslogtreecommitdiff
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorDhruvaraj Subhashchandran <dhruvaraj@in.ibm.com>2017-10-12 12:43:17 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-10-24 06:10:44 +0300
commit1ea01342eda55b45b6847efb4af9ae87e77e25e2 (patch)
tree68fa875f7db0338bb56c31a299afc0ecf4e31ed0 /meta-phosphor/common
parentc9f33777b36db69850eaae1a1b7dcfe03c32b8ad (diff)
downloadopenbmc-1ea01342eda55b45b6847efb4af9ae87e77e25e2.tar.xz
Install gevent-websocket to the image
gevent-websocket is a websocket handler for the gevent networking library. Websocket is used to push data out from the rest server to connected clients. Resolves openbmc/openbmc#2321 Change-Id: Ie381da1b0fd8b95e1fbb55d0063b3b7d9c1cc2c5 Signed-off-by: Dhruvaraj Subhashchandran <dhruvaraj@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb5
2 files changed, 6 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb
index ee24a1339..4301e6b83 100644
--- a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb
+++ b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb
@@ -14,6 +14,8 @@ RPROVIDES_${PN} += "virtual-obmc-wsgihost"
RDEPENDS_${PN} += " \
python-gevent \
"
+RRECOMMENDS_${PN} += "python-gevent-websocket"
+
S = "${WORKDIR}/git/servers/gevent"
diff --git a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb
index 6361f2598..a1a8cfdd4 100644
--- a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb
+++ b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb
@@ -9,7 +9,10 @@ inherit obmc-phosphor-discovery-service
require phosphor-rest.inc
-RRECOMMENDS_${PN} += "virtual-obmc-wsgihost"
+RRECOMMENDS_${PN} += " \
+ virtual-obmc-wsgihost \
+ python-gevent-websocket \
+ "
RDEPENDS_${PN} += " \
python-xml \