summaryrefslogtreecommitdiff
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-26 22:28:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-01 17:14:42 +0300
commit3fc171c9f6698dc47c6043cbfbf22bbbebf9be3f (patch)
tree88899d1db26d48e5dc38ab62390e1dc068842c47 /meta-phosphor/common
parent44e6f65025e43b7c80a795b51d84cf1cac42f2a9 (diff)
downloadopenbmc-3fc171c9f6698dc47c6043cbfbf22bbbebf9be3f.tar.xz
systemd: Add journald-dbus to PACKAGECONFIG
We carry a systemd patch that adds a new systemd configure option --enable-journald-dbus. Add it to PACKAGECONFIG and select it. Previously the patch selected the option by default. Add new files that are installed by the patch to FILES_${PN} to avoid unpackaged files errors from bitbake due to upstream systemd recipe changes in Rocko. Tested: Built and verified witherspoon and palmetto images Change-Id: Iaf72c2b039706287a00126035eafe2f8631ca473 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
index a18d67396..3b8a8d934 100644
--- a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
@@ -1,7 +1,7 @@
FILES_${PN}-catalog-extralocales = \
"${exec_prefix}/lib/systemd/catalog/*.*.catalog"
PACKAGES =+ "${PN}-catalog-extralocales"
-PACKAGECONFIG_append = " networkd coredump"
+PACKAGECONFIG_append = " networkd coredump journald-dbus"
PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
quotacheck kdbus ima smack polkit logind bootchart utmp \
manpages"
@@ -16,6 +16,11 @@ SRC_URI += "file://0004-basic-Use-path-escaping-when-mangling-path-instances.pat
#https://github.com/openbmc/openbmc/issues/2016
SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.patch"
SRC_URI += "file://0006-journal-Create-journald-dbus-object.patch"
+
+# Extra configuration for journald-dbus patch
+PACKAGECONFIG[journald-dbus] = "--enable-journald-dbus,--disable-journald-dbus"
+FILES_${PN} += "${datadir}/dbus-1/system.d/org.freedesktop.journal1.conf"
+
SRC_URI += "file://0007-journal-Add-Synchronize-dbus-method.patch"
SRC_URI += "${@mf_enabled(d, 'obmc-ubi-fs', 'file://software.conf')}"
SRC_URI += "file://0008-man-update-machine-id-5-with-a-note-about-privacy-46.patch"