summaryrefslogtreecommitdiff
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2017-10-12 09:47:31 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-10-12 17:54:32 +0300
commit5e9fff009c708855f255ec02efed26935f8ec2e0 (patch)
tree50cca8b1a05f0ad7540937ec7fdc790cfed31aea /meta-phosphor/common
parenteb5f189cc82ff0a1b5d1c7d3586e5ba74a4dc4e8 (diff)
downloadopenbmc-5e9fff009c708855f255ec02efed26935f8ec2e0.tar.xz
Customize inotify event initialization in UBI FS
Update core file inotify events on UBI FS based systems via a compiler flag. Change-Id: Id40b385d5b09d9fb6523694308e28d54ff53b78f Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
index f6c098e1e..c29c16ab4 100644
--- a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
+++ b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
@@ -75,3 +75,10 @@ do_install_append() {
install -m 0755 ${S}/tools/dreport \
${D}${bindir}/dreport
}
+
+#Enable ubifs-workaround by MACHINE_FEATURE obmc-ubi-fs.
+PACKAGECONFIG_append = "${@mf_enabled(d, 'obmc-ubi-fs', 'ubifs-workaround')}"
+PACKAGECONFIG[ubifs-workaround] = " \
+ --enable-ubifs-workaround, \
+ --disable-ubifs-workaround \
+"