summaryrefslogtreecommitdiff
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-23 20:28:00 +0300
committerPatrick Williams <patrick@stwcx.xyz>2016-06-24 23:22:18 +0300
commitf5139092b16dd06a04a3c35282f69f697ae08b39 (patch)
treee71bb21c84b82c8d5835529b5919c77b786b9bcd /meta-phosphor/common
parente30f60467556d63af8d7132579b3830bab0b6944 (diff)
downloadopenbmc-f5139092b16dd06a04a3c35282f69f697ae08b39.tar.xz
Fix systemd packageconfig
PACKAGECONFIG is typically set with '??=' in the base recipe. In our systemd append it was being set with += which overrides the weak default (??=) so none of the default configure options were used. This patch corrects that and then removes all the default options we don't need. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
index 8b3b25d34..9ad6a4057 100644
--- a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
@@ -1,4 +1,5 @@
-PACKAGECONFIG += "networkd"
+PACKAGECONFIG_append = " networkd"
+PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight quotacheck localed kdbus ima smack polkit"
FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
SRC_URI += "file://default.network"