summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-connectivity
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-phosphor/recipes-connectivity
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-connectivity')
-rw-r--r--meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend6
-rw-r--r--meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb4
-rw-r--r--meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend12
3 files changed, 11 insertions, 11 deletions
diff --git a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
index ee15899fa..5d0da5825 100644
--- a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
+++ b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
@@ -1,10 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/avahi-daemon:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/avahi-daemon:"
SRC_URI += "file://avahi-daemon-override.conf"
-FILES_avahi-daemon_append += "${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"
+FILES:avahi-daemon:append += "${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"
-do_install_append() {
+do_install:append() {
install -m 644 -D ${WORKDIR}/avahi-daemon-override.conf \
${D}${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf
diff --git a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
index 8533540dc..7381b3171 100644
--- a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
+++ b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
@@ -10,7 +10,7 @@ inherit autotools pkgconfig
DEPENDS += "json-c"
DEPENDS += "udev"
-RDEPENDS_${PN} += "nbd-client"
+RDEPENDS:${PN} += "nbd-client"
S = "${WORKDIR}/git"
@@ -19,7 +19,7 @@ SRCREV = "164fef38b703032045803f05301b256ed045a094"
NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/nbd-proxy/
install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
}
diff --git a/meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend b/meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend
index 0c5ed3b21..0bdb47b94 100644
--- a/meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend
+++ b/meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend
@@ -1,16 +1,16 @@
# General config settings.
-EXTRA_OECONF_append_class-target = " shared no-hw no-err no-psk no-srp "
+EXTRA_OECONF:append:class-target = " shared no-hw no-err no-psk no-srp "
# Disable SSL (keep TLS only).
-EXTRA_OECONF_append_class-target = " no-ssl2 no-ssl3 "
+EXTRA_OECONF:append:class-target = " no-ssl2 no-ssl3 "
# Disable various algorithms.
-EXTRA_OECONF_append_class-target = " no-md4 no-rmd160 no-whirlpool \
+EXTRA_OECONF:append:class-target = " no-md4 no-rmd160 no-whirlpool \
no-rc2 no-rc4 no-bf no-cast no-gost "
-do_configure_append() {
+do_configure:append() {
oe_runmake depend
}
# We don't want to depend on perl in our image
-RDEPENDS_${PN}-bin_remove = "perl"
-FILES_${PN}-misc_append = " ${bindir}/c_rehash"
+RDEPENDS:${PN}-bin:remove = "perl"
+FILES:${PN}-misc:append = " ${bindir}/c_rehash"