summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core/busybox
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-12-17 04:11:34 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-01-09 02:21:44 +0300
commit1a4b7ee28bf7413af6513fb45ad0d0736048f866 (patch)
tree79f6d8ea698cab8f2eaf4f54b793d2ca7a1451ce /meta-phosphor/recipes-core/busybox
parent5b9ede0403237c7dace972affa65cf64a1aadd0e (diff)
downloadopenbmc-1a4b7ee28bf7413af6513fb45ad0d0736048f866.tar.xz
reset upstream subtrees to yocto 2.6
Reset the following subtrees on thud HEAD: poky: 87e3a9739d meta-openembedded: 6094ae18c8 meta-security: 31dc4e7532 meta-raspberrypi: a48743dc36 meta-xilinx: c42016e2e6 Also re-apply backports that didn't make it into thud: poky: 17726d0 systemd-systemctl-native: handle Install wildcards meta-openembedded: 4321a5d libtinyxml2: update to 7.0.1 042f0a3 libcereal: Add native and nativesdk classes e23284f libcereal: Allow empty package 030e8d4 rsyslog: curl-less build with fmhttp PACKAGECONFIG 179a1b9 gtest: update to 1.8.1 Squashed OpenBMC subtree compatibility updates: meta-aspeed: Brad Bishop (1): aspeed: add yocto 2.6 compatibility meta-ibm: Brad Bishop (1): ibm: prepare for yocto 2.6 meta-ingrasys: Brad Bishop (1): ingrasys: set layer compatibility to yocto 2.6 meta-openpower: Brad Bishop (1): openpower: set layer compatibility to yocto 2.6 meta-phosphor: Brad Bishop (3): phosphor: set layer compatibility to thud phosphor: libgpg-error: drop patches phosphor: react to fitimage artifact rename Ed Tanous (4): Dropbear: upgrade options for latest upgrade yocto2.6: update openssl options busybox: remove upstream watchdog patch systemd: Rebase CONFIG_CGROUP_BPF patch Change-Id: I7b1fe71cca880d0372a82d94b5fd785323e3a9e7 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-core/busybox')
-rw-r--r--meta-phosphor/recipes-core/busybox/busybox/0001-Stop-watchdog-first-on-startup.patch63
-rw-r--r--meta-phosphor/recipes-core/busybox/busybox_%.bbappend1
2 files changed, 0 insertions, 64 deletions
diff --git a/meta-phosphor/recipes-core/busybox/busybox/0001-Stop-watchdog-first-on-startup.patch b/meta-phosphor/recipes-core/busybox/busybox/0001-Stop-watchdog-first-on-startup.patch
deleted file mode 100644
index 7128b8108..000000000
--- a/meta-phosphor/recipes-core/busybox/busybox/0001-Stop-watchdog-first-on-startup.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From a4c493ae42926ab36fdc805a5da9f0682bb98b45 Mon Sep 17 00:00:00 2001
-From: Matt Spinler <spinler@us.ibm.com>
-Date: Tue, 13 Jun 2017 15:26:49 -0500
-Subject: [PATCH] Stop watchdog first on startup
-
-Some watchdog implementations may do things other than issue
-a reboot on a watchdog timeout. In this case, there's the
-possibility of restarting this program from the state of
-the watchdog device not being properly stopped (done by writing
-a 'V' and closing the device). Since it wasn't stopped, the
-driver may not be able to restart the watchdog when this program
-reopens it and starts pinging it.
-
-To fix this, the code will always first issue the stop when it
-starts up.
-
-Signed-off-by: Matt Spinler <spinler@us.ibm.com>
----
- miscutils/watchdog.c | 21 +++++++++++++++++++--
- 1 file changed, 19 insertions(+), 2 deletions(-)
-
-diff --git a/miscutils/watchdog.c b/miscutils/watchdog.c
-index 07ae64e52..223e3c32d 100644
---- a/miscutils/watchdog.c
-+++ b/miscutils/watchdog.c
-@@ -53,6 +53,24 @@ static void watchdog_shutdown(int sig UNUSED_PARAM)
- _exit(EXIT_SUCCESS);
- }
-
-+static void watchdog_open(const char* device)
-+{
-+ static const char magic_value = 'V';
-+
-+ /* If the watchdog driver can do something other than cause a reboot
-+ * on a timeout, then it's possible this program may be starting from
-+ * a state when the watchdog hadn't been previously stopped with
-+ * the magic write followed by a close. In this case the driver may
-+ * not start properly, so always do the proper stop first just in case.
-+ */
-+
-+ /* Use known fd # - avoid needing global 'int fd' */
-+ xmove_fd(xopen(device, O_WRONLY), 3);
-+ write(3, &magic_value, 1);
-+ close(3);
-+ xmove_fd(xopen(device, O_WRONLY), 3);
-+}
-+
- int watchdog_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
- int watchdog_main(int argc, char **argv)
- {
-@@ -88,8 +106,7 @@ int watchdog_main(int argc, char **argv)
-
- bb_signals(BB_FATAL_SIGS, watchdog_shutdown);
-
-- /* Use known fd # - avoid needing global 'int fd' */
-- xmove_fd(xopen(argv[argc - 1], O_WRONLY), 3);
-+ watchdog_open(argv[argc - 1]);
-
- /* WDIOC_SETTIMEOUT takes seconds, not milliseconds */
- htimer_duration = htimer_duration / 1000;
---
-2.11.0
-
diff --git a/meta-phosphor/recipes-core/busybox/busybox_%.bbappend b/meta-phosphor/recipes-core/busybox/busybox_%.bbappend
index cc88bcc40..8907b08e0 100644
--- a/meta-phosphor/recipes-core/busybox/busybox_%.bbappend
+++ b/meta-phosphor/recipes-core/busybox/busybox_%.bbappend
@@ -2,5 +2,4 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://busybox.cfg"
SRC_URI += "file://flash.cfg"
SRC_URI += "file://mountpoint.cfg"
-SRC_URI += "file://0001-Stop-watchdog-first-on-startup.patch"
SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', '', 'file://reboot.cfg', d)}"