summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core/os-release/os-release.bbappend
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2021-02-10 03:29:27 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-06-23 22:20:25 +0300
commit439c59b425cf403355571875b3fa714782dcf15b (patch)
tree172f346d59f60306491752ed6a42c0a08ba286ec /meta-phosphor/recipes-core/os-release/os-release.bbappend
parent4ad716c1407b626754888cee8a1c63a67edd6526 (diff)
downloadopenbmc-439c59b425cf403355571875b3fa714782dcf15b.tar.xz
meta-phosphor: os-release: Set weak default to DISTRO_VERSION
Improved practice to use DISTRO_VERSION instead of the undocumented VERSION_ID. DISTRO_VERSION is documented in yocto https://www.yoctoproject.org/docs/latest/ref-manual/ref-manual.html and specified in this section about creating your own distribution. https://docs.yoctoproject.org/dev-manual/common-tasks.html#creating-your-own-distribution VERSION_ID is undocumented and will more likely be changed compared to the documented DISTRO_VERSION. The VERSION_ID is set to DISTRO_VERSION in poky/.../os-release.bb Use weak default to DISTRO_VERSION instead of overriding VERSION_ID. This allows other layers to override in *.bbappend or *.conf. Tested: ``` root@romulus:~# cat /etc/os-release ID=openbmc-openpower NAME="Phosphor OpenBMC (Phosphor OpenBMC Project Reference Distro)" VERSION="2.11.0-dev" VERSION_ID=2.11.0-dev-165-g20885c497 PRETTY_NAME="Phosphor OpenBMC (Phosphor OpenBMC Project Reference Distro) 2.11.0-dev" BUILD_ID="2.11.0-dev" OPENBMC_TARGET_MACHINE="romulus" ``` Signed-off-by: Willy Tu <wltu@google.com> Change-Id: I25b5a165b764e6562fa8008c9d2a75a82fb09139
Diffstat (limited to 'meta-phosphor/recipes-core/os-release/os-release.bbappend')
-rw-r--r--meta-phosphor/recipes-core/os-release/os-release.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-core/os-release/os-release.bbappend b/meta-phosphor/recipes-core/os-release/os-release.bbappend
index 15852327f..f42235e4c 100644
--- a/meta-phosphor/recipes-core/os-release/os-release.bbappend
+++ b/meta-phosphor/recipes-core/os-release/os-release.bbappend
@@ -15,7 +15,7 @@ def run_git(d, cmd):
bb.warn("Unexpected exception from 'git' call: %s" % e)
pass
-VERSION_ID := "${@run_git(d, 'describe --dirty')}"
+DISTRO_VERSION ??= "${@run_git(d, 'describe --dirty')}"
VERSION = "${@'-'.join(d.getVar('VERSION_ID').split('-')[0:2])}"
BUILD_ID := "${@run_git(d, 'describe --abbrev=0')}"