summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core/os-release
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-10-22 21:50:40 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-26 17:33:21 +0300
commit2877a0ca45b93b4f74a4b58a09256623411b1bf4 (patch)
treeaf4c72ac4e04744c6866ad8bf5de78c8128ded8b /meta-phosphor/recipes-core/os-release
parent583147ea45f94ee363e9ae30ccb65b9ed1561b54 (diff)
downloadopenbmc-2877a0ca45b93b4f74a4b58a09256623411b1bf4.tar.xz
os-release: only run bbappend on do_compile
Chasing an intermittent os-release build failure via openbmc/openbmc#3720. Not clear if this fix will resolve that issue but there does not appear to be any reason to run the logic in the bbappend outside of the do_compile step since that is the only place the OS_RELEASE_FIELDS are utilized by the base recipe. (From meta-phosphor rev: f2b07859cc9586f96b072678d1f5f4586e77850b) Change-Id: I5f14da2babc852f3d39f2ca6bae4bf993d5e22da Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-core/os-release')
-rw-r--r--meta-phosphor/recipes-core/os-release/os-release.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-core/os-release/os-release.bbappend b/meta-phosphor/recipes-core/os-release/os-release.bbappend
index c01014643..1c98781c8 100644
--- a/meta-phosphor/recipes-core/os-release/os-release.bbappend
+++ b/meta-phosphor/recipes-core/os-release/os-release.bbappend
@@ -13,7 +13,7 @@ def run_git(d, cmd):
except:
pass
-python() {
+python do_compile_prepend() {
version_id = run_git(d, 'describe --dirty --long')
if version_id:
d.setVar('VERSION_ID', version_id)