summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core/packagegroups
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-09-08 19:32:19 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-13 18:05:54 +0300
commit38bc34255f56604b443c12836891108632c41e80 (patch)
tree9abc5e5252d91035b09b24ddf12fcdccdc5edc25 /meta-phosphor/recipes-core/packagegroups
parentae630343d9f180a6fc8cc5f2c48af76064e6e3cd (diff)
downloadopenbmc-38bc34255f56604b443c12836891108632c41e80.tar.xz
phosphor-dbus-interfaces: remove native support
The native and nativesdk packages for PDI were previously used as the mechanism to install YAML files. Within the image, the -native packages are no longer used and instead there is a target -yaml package which contains the YAML files. As a follow up, we can now do the three items: * Remove nativesdk-PDI from SDK. * Add target PDI-yaml to the SDK. * Remove native/native-sdk support from PDI recipes. (From meta-phosphor rev: 4f00c4b4504951324c78183a3ed6e8cbc8f2580c) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ic049da4855df7e19225e7acd9eeb16efaa9808d1 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-core/packagegroups')
-rw-r--r--meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend1
-rw-r--r--meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend8
2 files changed, 7 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
index a3e2dcda2..e111a4d95 100644
--- a/meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
+++ b/meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
@@ -1,7 +1,6 @@
RDEPENDS_${PN}_append = " \
nativesdk-autoconf-archive \
nativesdk-meson \
- nativesdk-phosphor-dbus-interfaces-yaml \
nativesdk-python3-sdbus++ \
nativesdk-phosphor-logging-elog \
"
diff --git a/meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend b/meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
index d62dc9985..8327383d0 100644
--- a/meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
+++ b/meta-phosphor/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
@@ -1 +1,7 @@
-RRECOMMENDS_${PN}_append = " googletest sdbusplus phosphor-logging libstdc++-staticdev"
+RRECOMMENDS_${PN}_append = " \
+ googletest \
+ libstdc++-staticdev \
+ phosphor-dbus-interfaces-yaml \
+ phosphor-logging \
+ sdbusplus \
+ "