summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2019-07-10 05:25:13 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-11 02:17:04 +0300
commit3cd63893e308805cbd4202383e7f711f655e22cb (patch)
tree287b591ff355703f6761f8b798513e9df98aed05 /meta-phosphor/recipes-core/systemd/systemd_%.bbappend
parent91259439acee536b2e2be40066924e817bdabc16 (diff)
downloadopenbmc-3cd63893e308805cbd4202383e7f711f655e22cb.tar.xz
systemd: Fix networking with Linux 5.2
These two patches are backported from systemd master in order to fix an upstream bug with 5.2 kernels where the network interface fails to come up with the following error: eth0: Could not bring up interface: Invalid argument The patches will appear in systemd 243, which is unrelased at this time. (From meta-phosphor rev: 8c4686c5d242ae045a79dfb768af54361c462e6a) Resolves https://github.com/systemd/systemd/issues/12784 Change-Id: I69388952c8269b9d0063623e664ad50b538d0b26 Signed-off-by: Joel Stanley <joel@jms.id.au> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--meta-phosphor/recipes-core/systemd/systemd_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
index f9d830157..5660e7cbf 100644
--- a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
@@ -8,6 +8,10 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://default.network"
SRC_URI += "file://0001-sd-bus-Don-t-automatically-add-ObjectManager.patch"
+# Backport from master to fix https://github.com/systemd/systemd/issues/12784
+SRC_URI += "file://0001-networkd-fix-link_up-12505.patch"
+SRC_URI += "file://0002-network-do-not-send-ipv6-token-to-kernel.patch"
+
RRECOMMENDS_${PN} += "obmc-targets"
FILES_${PN} += "${systemd_unitdir}/network/default.network"