summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core
diff options
context:
space:
mode:
authorChanh Nguyen <chanh@amperemail.onmicrosoft.com>2021-01-29 10:40:58 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-02-10 03:46:53 +0300
commit14c44a7b58c819ae550dda6fd298115503820a7e (patch)
tree5d2df717627cca9dde83a18b8a55cc2ab2eb1cd7 /meta-phosphor/recipes-core
parentd35004fcfe2640008d134d38ddb9b48c42cce140 (diff)
downloadopenbmc-14c44a7b58c819ae550dda6fd298115503820a7e.tar.xz
os-release: add EXTENDED_VERSION to /etc/os-release
This adds a new OS identification parameter (EXTENDED_VERSION) to the /etc/os-release file in the generated OpenBMC image to indicate the extended version of the OpenBMC image. Note the extended version is typically set in the openbmc/meta-*/meta-MACHINE/conf/local.conf.sample file (This is where TEMPLATECONF points to.) by "EXTENDED_VERSION" variable. Tested: On the build system, `cat $IMAGE_ROOTFS/etc/os-release` shows the correct value. Signed-off-by: Chanh Nguyen <chanh@amperemail.onmicrosoft.com> Change-Id: I34d52e3799d83902e12be95d12f4036b70d721cd
Diffstat (limited to 'meta-phosphor/recipes-core')
-rw-r--r--meta-phosphor/recipes-core/os-release/os-release.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-core/os-release/os-release.bbappend b/meta-phosphor/recipes-core/os-release/os-release.bbappend
index 4c9e157a2..15852327f 100644
--- a/meta-phosphor/recipes-core/os-release/os-release.bbappend
+++ b/meta-phosphor/recipes-core/os-release/os-release.bbappend
@@ -21,7 +21,7 @@ VERSION = "${@'-'.join(d.getVar('VERSION_ID').split('-')[0:2])}"
BUILD_ID := "${@run_git(d, 'describe --abbrev=0')}"
OPENBMC_TARGET_MACHINE = "${MACHINE}"
-OS_RELEASE_FIELDS_append = " BUILD_ID OPENBMC_TARGET_MACHINE"
+OS_RELEASE_FIELDS_append = " BUILD_ID OPENBMC_TARGET_MACHINE EXTENDED_VERSION"
# Ensure the git commands run every time bitbake is invoked.
BB_DONT_CACHE = "1"