summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools/iotools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-devtools/iotools
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-devtools/iotools')
-rw-r--r--meta-phosphor/recipes-devtools/iotools/iotools/iotools-setup.service11
-rw-r--r--meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb26
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-devtools/iotools/iotools/iotools-setup.service b/meta-phosphor/recipes-devtools/iotools/iotools/iotools-setup.service
new file mode 100644
index 000000000..7cc95a0db
--- /dev/null
+++ b/meta-phosphor/recipes-devtools/iotools/iotools/iotools-setup.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Install iotool links
+
+[Service]
+RemainAfterExit=no
+Type=oneshot
+ExecStart=/usr/bin/env iotools --make-links
+SystlogIdentifier=iotools
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb b/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
new file mode 100644
index 000000000..af2cc76ac
--- /dev/null
+++ b/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Command line tools for hardware device registers"
+HOMEPAGE = "https://github.com/jonmayergoogle/iotools"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+SRCREV = "8d928b3360246b8ead95b442ca3887ce8b8f942f"
+SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https"
+PV = "v1.6+git${SRCPV}"
+
+inherit obmc-phosphor-systemd
+
+S = "${WORKDIR}/git"
+FILES_${PN} = "${sbindir}"
+
+do_compile() {
+ # CC is overridden in the Makefile, so override it harder in the invocation
+ oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
+}
+
+# The "install" make target runs the binary to create links for subcommands.
+# The links are excessive and this doesn't work for cross compiling.
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 iotools ${D}${sbindir}
+}
+
+SYSTEMD_SERVICE_${PN} += "iotools-setup.service"