summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools/python
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-04-14 19:26:24 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-23 21:36:14 +0300
commitb2808374702ec7cf5902258f27a055b4e3411039 (patch)
tree1780cbb20dee7857b970080447b076e5140af83c /meta-phosphor/recipes-devtools/python
parent68be0733e1e11cb5173abc15b8a90ab85d8c3ec4 (diff)
downloadopenbmc-b2808374702ec7cf5902258f27a055b4e3411039.tar.xz
dunfell: ensurepip not needed in rootfs
This was pulled down from the facebook/openbmc repo: https://github.com/facebook/openbmc/blob/19cd2a3e9638e7a2652518c022e422c7de4c7259/common/recipes-devtools/python/python3_%25.bbappend (From meta-phosphor rev: d23fed577d26eb704e427a4f65f13866cb391de1) Change-Id: I5cb44b0e3b634bf0d605e84e3d32a15e84615354 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-devtools/python')
-rw-r--r--meta-phosphor/recipes-devtools/python/python3_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python3_%.bbappend b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
index f689a9e91..5d5e38a7b 100644
--- a/meta-phosphor/recipes-devtools/python/python3_%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
@@ -3,3 +3,9 @@ inherit update-alternatives
ALTERNATIVE_${PN}-core += "python"
ALTERNATIVE_LINK_NAME[python] = "${bindir}/python"
ALTERNATIVE_TARGET[python] = "${bindir}/python3"
+
+# Even though python3 is built with --without-ensurepip, it still installs
+# a large, compressed version of pip. Remove it to free up the space.
+do_install_append_class-target() {
+ rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip
+}