summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2020-03-30 15:18:18 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-01 16:35:54 +0300
commit172916ced2b5a46fcf5a177bda791abec3362929 (patch)
tree4f2e446912b486a1c4cdd0c327395f39f3957c46 /meta-phosphor/recipes-devtools
parent04b85e9f7cb38c97af7b30d45f912c48183f06e0 (diff)
downloadopenbmc-172916ced2b5a46fcf5a177bda791abec3362929.tar.xz
Remove /usr/bin/py.test and /usr/bin/pytest from install path
When moving to python3 and building openbmc, Yocto throws a QA issue in that, both python2 and python3 attempt to install /usr/bin/py.test, which is not used and hence this commit deletes the file (From meta-phosphor rev: 34ec91f787555b2d5086cc1e8c61c8e8833726f3) Change-Id: Ib7aca05972525e0edf6ad3b2c1f29759d761084c Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/python/python-pytest_%.bbappend13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python-pytest_%.bbappend b/meta-phosphor/recipes-devtools/python/python-pytest_%.bbappend
new file mode 100644
index 000000000..e8dd736ef
--- /dev/null
+++ b/meta-phosphor/recipes-devtools/python/python-pytest_%.bbappend
@@ -0,0 +1,13 @@
+# python-pytest installs /usr/bin/pytest for both python2 and python3,
+# which causes a bitbake QA failure. Remove it from installation for the
+# native target to avoid the collision.
+#
+# We don't currently use this as a target package and if we did, we shouldn't
+# install both python2 and python3 variants.
+#
+# Once we are done with python2, we can delete this.
+
+do_install_append_class-native() {
+ rm ${D}${bindir}/py.test
+ rm ${D}${bindir}/pytest
+}