summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-04-14 17:04:52 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-23 21:38:23 +0300
commit358dfea6a0767d615d9f6f00ea3a78e6ba86d850 (patch)
tree5afba2df92dedcabfc02543382f38b20df1b8bdc /meta-phosphor/recipes-devtools
parent1b933da8a732fd969dc230fb07442fbafa6a1dca (diff)
downloadopenbmc-358dfea6a0767d615d9f6f00ea3a78e6ba86d850.tar.xz
dunfell: fix up inherits for python3
Most of these recipes are no longer needed but bitbake still verifies the inherit clauses for them. python2 has been removed so need these to all use the corresponding python3 classes. (From meta-phosphor rev: d55b42ae26bf5198efeb38db9eed8166139408bd) Change-Id: Idf5fee957d8d0f3128a766a8007c3053fc1464d9 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/python/pyphosphor_git.bb4
-rw-r--r--meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb b/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
index 1274c1240..a0383d5fd 100644
--- a/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
+++ b/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
@@ -7,8 +7,8 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit allarch
-inherit setuptools
-inherit python-dir
+inherit setuptools3
+inherit python3-dir
PACKAGE_BEFORE_PN = " \
${PN}-ns \
diff --git a/meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb b/meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb
index 73ac563dc..cf0eb5db5 100644
--- a/meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb
+++ b/meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb
@@ -34,7 +34,7 @@ S = "${WORKDIR}/pygobject-${PV}"
EXTRA_OECONF += "--disable-introspection"
-inherit autotools distutils-base pkgconfig
+inherit autotools distutils3-base pkgconfig
# necessary to let the call for python-config succeed
export BUILD_SYS