summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-02-25 19:52:39 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-16 18:49:58 +0300
commit741c05d54580c2ac10d7751728f45a0c891ac435 (patch)
tree9ebf6712b4cf83202d8494ed3c221227823fdb87 /meta-phosphor/recipes-devtools
parent276f647402307b9ca76f45bd2fd28bfa5e8acf47 (diff)
downloadopenbmc-741c05d54580c2ac10d7751728f45a0c891ac435.tar.xz
python-mako: remove mako-render from native recipe
Both python-mako and python3-mako attempt to install an executable into /usr/bin/mako-render. Neither of these are used by anything in openbmc. Delete the executable for python-mako-native to avoid the collision. Once we are done with python2 this can be deleted. (From meta-phosphor rev: e0d4ebcd479297ef8659112cfb8d627165c26c9e) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I75b4b28ed2804a02ba8bc487f68ec0a67c3e4a49 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/python/python-mako_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python-mako_%.bbappend b/meta-phosphor/recipes-devtools/python/python-mako_%.bbappend
new file mode 100644
index 000000000..020bdd6ab
--- /dev/null
+++ b/meta-phosphor/recipes-devtools/python/python-mako_%.bbappend
@@ -0,0 +1,12 @@
+# python-mako installs /usr/bin/mako-render for both python2 and python3,
+# which causes a bitbake QA failure. Remove it from installation for the
+# native target to avoid the collision.
+#
+# We don't currently use this as a target package and if we did, we shouldn't
+# install both python2 and python3 variants.
+#
+# Once we are done with python2, we can delete this.
+
+do_install_append_class-native() {
+ rm ${D}${bindir}/mako-render
+}