summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-03-31 22:22:32 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-01 16:35:56 +0300
commit8a35fe127f28c24aaf58073e7293d14a4e4bb1d2 (patch)
treeb6a0a92d9aa5099786e243e3d0aaec8a3964cb8c /meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
parent2e595329f744f43b744fa7a825d369f5f511d362 (diff)
downloadopenbmc-8a35fe127f28c24aaf58073e7293d14a4e4bb1d2.tar.xz
sdbusplus: split library and python scripts
(From meta-phosphor rev: 7aba8156394c5608565e549a1b9de3e9a91b5ff1) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I471c25139f9fef8c976613a9f8c25d7617c1aa8c Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb37
1 files changed, 7 insertions, 30 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index a44000351..1709906c1 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -12,38 +12,15 @@ DEPENDS += " \
${PYTHON_PN}-mako-native \
${PYTHON_PN}-pyyaml-native \
"
-RDEPENDS_sdbus++ += " \
- ${PYTHON_PN} \
- ${PYTHON_PN}-inflection \
- ${PYTHON_PN}-mako \
- ${PYTHON_PN}-pyyaml \
- "
-
-# sdbus++ has a handful of runtime dependencies on other python packages.
-# Bitbake doesn't do anything with RDEPENDS in native context because
-# native context doesn't have packages.
-#
-# While technically sdbus++ doesn't require its runtime dependencies to be
-# installed to build, work around the above native context behavior
-# by adding a build dependency so that clients don't have to DEPEND
-# on sdbus++ runtime dependencies manually.
-
-DEPENDS_append_class-native = " \
- ${PYTHON_PN}-inflection-native \
- ${PYTHON_PN}-mako-native \
- ${PYTHON_PN}-pyyaml-native \
- "
PACKAGECONFIG ??= "libsdbusplus transaction"
PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
-PROVIDES_prepend = "sdbus++ "
-PACKAGE_BEFORE_PN = "sdbus++"
-FILES_sdbus++_append = " ${bindir}/sdbus++"
-PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
-
-PACKAGECONFIG_remove_class-native = "libsdbusplus"
-PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
-
-BBCLASSEXTEND += "native nativesdk"
+# Remove unused sdbus++ contents (included in python3-sdbus++ package).
+do_install_append() {
+ rm ${D}/${bindir}/sdbus++
+ rmdir ${D}/${bindir} || true
+ rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR}
+ rmdir ${D}/${libdir}/${PYTHON_DIR} || true
+}