summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/datetime
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/datetime
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/datetime')
-rw-r--r--meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager/xyz.openbmc_project.Time.Manager.service18
-rw-r--r--meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb30
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager/xyz.openbmc_project.Time.Manager.service b/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager/xyz.openbmc_project.Time.Manager.service
new file mode 100644
index 000000000..e819e35ac
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager/xyz.openbmc_project.Time.Manager.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Phosphor Time Manager daemon
+Wants=mapper-wait@-xyz-openbmc_project-time-owner.service
+After=mapper-wait@-xyz-openbmc_project-time-owner.service
+Wants=mapper-wait@-xyz-openbmc_project-time-sync_method.service
+After=mapper-wait@-xyz-openbmc_project-time-sync_method.service
+Wants=mapper-wait@-xyz-openbmc_project-state-host0.service
+After=mapper-wait@-xyz-openbmc_project-state-host0.service
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env phosphor-timemanager
+SyslogIdentifier=phosphor-timemanager
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb b/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
new file mode 100644
index 000000000..59fa7b518
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Phosphor Time Manager daemon"
+DESCRIPTION = "Daemon to cater to BMC and HOST time management"
+HOMEPAGE = "http://github.com/openbmc/phosphor-time-manager"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+inherit autotools pkgconfig pythonnative
+inherit obmc-phosphor-dbus-service
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "phosphor-mapper"
+DEPENDS += "systemd"
+DEPENDS += "sdbusplus"
+DEPENDS += "sdbusplus-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "phosphor-dbus-interfaces"
+RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-settings-mgmt}"
+RDEPENDS_${PN} += "network"
+RDEPENDS_${PN} += "libmapper"
+RDEPENDS_${PN} += "libsystemd"
+RDEPENDS_${PN} += "sdbusplus"
+RDEPENDS_${PN} += "phosphor-dbus-interfaces"
+
+SRC_URI += "git://github.com/openbmc/phosphor-time-manager"
+SRCREV = "33752c75e8bdadf13d983e94667de72f64ba3537"
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.Time.Manager.service"