summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb b/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
new file mode 100644
index 000000000..8290ecce2
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Phosphor OpenBMC DBUS Permissions"
+DESCRIPTION = "Phosphor OpenBMC DBUS Permissions."
+HOMEPAGE = "http://github.com/openbmc/"
+PR = "r1"
+
+inherit allarch
+inherit obmc-phosphor-license
+inherit dbus-dir
+
+SRC_URI += "file://org.openbmc.conf"
+
+do_install_append() {
+ install -d ${D}${dbus_system_confdir}
+ install -m 0644 ${WORKDIR}/org.openbmc.conf \
+ ${D}${dbus_system_confdir}
+}