summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-10-04 22:42:48 +0300
committerGitHub <noreply@github.com>2021-10-04 22:42:48 +0300
commit0c9e31989c615598b5d042ffab385606660c93c0 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-phosphor/recipes-phosphor/dbus
parent04cd92067d2481643df5010cb39b2134b648cf4d (diff)
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
downloadopenbmc-0c9e31989c615598b5d042ffab385606660c93c0.tar.xz
Merge pull request #72 from Intel-BMC/update2021-0.751-0.75
Update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb4
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb6
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb6
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb4
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb15
7 files changed, 19 insertions, 20 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb b/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
index b194740d3..ca60b6931 100644
--- a/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
@@ -10,7 +10,7 @@ inherit dbus-dir
SRC_URI += "file://org.openbmc.conf"
-do_install_append() {
+do_install:append() {
install -d ${D}${dbus_system_confdir}
install -m 0644 ${WORKDIR}/org.openbmc.conf \
${D}${dbus_system_confdir}
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb
index 3dfc3b1a6..dda33fa99 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb
@@ -9,5 +9,5 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit phosphor-mapper
inherit native
-PHOSPHOR_MAPPER_SERVICE_append = " xyz.openbmc_project"
-PHOSPHOR_MAPPER_INTERFACE_append = " xyz.openbmc_project org.freedesktop.DBus.ObjectManager"
+PHOSPHOR_MAPPER_SERVICE:append = " xyz.openbmc_project"
+PHOSPHOR_MAPPER_INTERFACE:append = " xyz.openbmc_project org.freedesktop.DBus.ObjectManager"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 98a5c7881..4132585f5 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -18,7 +18,7 @@ DEPENDS += " \
"
SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces"
-SRCREV = "5795dacbc5763a0f1d1e1ac59d73baf4ca2ae616"
+SRCREV = "6b50623459b54af222cb9a79c5a0c7912c92da41"
# Process OBMC_ORG_YAML_SUBDIRS to create Meson config options.
# ex. xyz/openbmc_project -> -Ddata_xyz_openbmc_project=true
@@ -31,8 +31,8 @@ pdi_meson_config[vardeps] = "OBMC_ORG_YAML_SUBDIRS"
# Markdown files are installed into /usr/share/phosphor-dbus-interfaces so
# add them to the 'doc' subpackage.
-FILES_${PN}-doc += "${datadir}/${BPN}"
+FILES:${PN}-doc += "${datadir}/${BPN}"
-EXTRA_OEMESON_append = " \
+EXTRA_OEMESON:append = " \
-Db_lto=true \
${@pdi_meson_config(d)}"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
index d1de054be..dddf9c04c 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
@@ -19,4 +19,4 @@ do_install() {
mkdir -p ${D}${config_dir}
}
-FILES_${PN} += "${config_dir}"
+FILES:${PN} += "${config_dir}"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
index cc0b5c631..8cc9c089f 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor"
-SRCREV = "995060c14f7c017db6ebf3a33d622ff0858b6ba2"
+SRCREV = "b839c3ea01044e38b7beb37e8920ccc31f3c6519"
inherit autotools \
pkgconfig \
@@ -17,7 +17,7 @@ inherit autotools \
PACKAGE_BEFORE_PN = "phosphor-msl-verify"
SYSTEMD_PACKAGES = "${PN} phosphor-msl-verify"
-SYSTEMD_SERVICE_phosphor-msl-verify = "phosphor-msl-verify.service"
+SYSTEMD_SERVICE:phosphor-msl-verify = "phosphor-msl-verify.service"
DEPENDS += " \
${PN}-config \
@@ -33,7 +33,7 @@ DEPENDS += " \
${PYTHON_PN}-mako-native \
"
-FILES_phosphor-msl-verify = "${bindir}/phosphor-msl-verify"
+FILES:phosphor-msl-verify = "${bindir}/phosphor-msl-verify"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
index c92351214..2682ba37c 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
@@ -8,5 +8,5 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit phosphor-mapper
inherit native
-PHOSPHOR_MAPPER_SERVICE_append = " org.openbmc"
-PHOSPHOR_MAPPER_INTERFACE_append = " org.openbmc"
+PHOSPHOR_MAPPER_SERVICE:append = " org.openbmc"
+PHOSPHOR_MAPPER_INTERFACE:append = " org.openbmc"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
index d5e919812..3ea5bffa0 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
@@ -6,38 +6,37 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
-inherit autotools pkgconfig
+inherit meson pkgconfig
inherit obmc-phosphor-dbus-service
inherit obmc-phosphor-systemd
inherit phosphor-mapperdir
DEPENDS += "systemd"
-DEPENDS += "autoconf-archive-native"
DEPENDS += "boost"
DEPENDS += "libtinyxml2"
DEPENDS += "sdbusplus"
DEPENDS += "phosphor-logging"
DEPENDS += "${PN}-config-native"
-DBUS_SERVICE_${PN} += "xyz.openbmc_project.ObjectMapper.service"
-SYSTEMD_SERVICE_${PN} += " \
+DBUS_SERVICE:${PN} += "xyz.openbmc_project.ObjectMapper.service"
+SYSTEMD_SERVICE:${PN} += " \
mapper-wait@.service \
mapper-subtree-remove@.service \
"
SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
-SRCREV = "bdaa7f8bb4b34ec4d5f806135364e3ffcc427c0e"
+SRCREV = "bedd41655ed9641a9f6c47079e811797869ad8f3"
S = "${WORKDIR}/git"
-EXTRA_OECONF += "--disable-tests"
+EXTRA_OEMESON += "-Dtests=disabled"
-python populate_packages_prepend () {
+python populate_packages:prepend () {
mapperlibdir = d.getVar("libdir", True)
do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
}
PACKAGES_DYNAMIC += "^libmapper.*"
-FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"
+FILES:${PN}:remove = "${libdir}/lib*.so.* ${libdir}/*"
# Construct a systemd environment file with mapper commandline
# from the native sysroot /usr/share/phosphor-mapper filesystem.