summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
diff options
context:
space:
mode:
authorMarri Devender Rao <devenrao@in.ibm.com>2018-11-21 15:30:36 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-01-23 18:36:10 +0300
commit5035fcf95767a51c7ff3f72bfd75813458099129 (patch)
treee996d91f30492f84a2c5a8ff3fc080958f3a531f /meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
parent39803765763df44c3e6fd456d652cb21bae3c628 (diff)
downloadopenbmc-5035fcf95767a51c7ff3f72bfd75813458099129.tar.xz
phosphor-debug-collector: Phosphor Pass errors to watch through YAML file
Refactored code to pass error objects to watch through YAML file Dump will be created when an error object created matches the error object path specified in the YAML file. (From meta-phosphor rev: ae622549f4947084e549ec5cfc40f88daa5c4ae6) Change-Id: I9eb1c53ee4e1580d903e1004009d7595fb7811a6 Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
new file mode 100644
index 000000000..7a6870c5d
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Debug collector error watch config file"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+
+SRC_URI += "file://errors_watch.yaml"
+
+PROVIDES += "virtual/phosphor-debug-errors"
+
+S = "${WORKDIR}"
+
+do_install_append() {
+ DEST=${D}${datadir}/dump
+ install -d ${DEST}
+ install errors_watch.yaml ${DEST}/
+}
+