summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump
diff options
context:
space:
mode:
authorRamesh Iyyar <rameshi1@in.ibm.com>2020-08-21 11:57:44 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-26 03:49:32 +0300
commit42e76b3b45a8ac23ed0b487ec39c1b155ebeb321 (patch)
tree67061d2188fc1c26dfabf4c4fc62eef77899c08f /meta-phosphor/recipes-phosphor/dump
parentb2fe863db1c3690813aab4707203ed8fbcdc7d52 (diff)
downloadopenbmc-42e76b3b45a8ac23ed0b487ec39c1b155ebeb321.tar.xz
meta-phosphor: dump: Switched to meson build tool
The phosphor-debug-collector is now supporting meson build infrastructure to build phosphor-debug-collector so, switching to meson build tool instead using autotools for reducing the bmc build time. phosphor-debug-collector meson build tool patch set: https://gerrit.openbmc-project.xyz/c/openbmc/phosphor-debug-collector/+/35282 SRCREV bump: 9b841d...bb410d Ramesh Iyyar (1): build: Enabled meson build infrastructure Tested: - Image build: - MACHINE=witherspoon DISTRO=openbmc-witherspoon \ TEMPLATECONF=meta-ibm/conf bitbake obmc-phosphor-image - MACHINE=witherspoon-tacoma DISTRO=openbmc-witherspoon \ TEMPLATECONF=meta-ibm/conf bitbake obmc-phosphor-image - SDK build: - MACHINE=witherspoon DISTRO=openbmc-witherspoon \ TEMPLATECONF=meta-ibm/conf bitbake obmc-phosphor-image -c populate_sdk - MACHINE=witherspoon-tacoma DISTRO=openbmc-witherspoon \ TEMPLATECONF=meta-ibm/conf bitbake obmc-phosphor-image -c populate_sdk (From meta-phosphor rev: b5f0cdd0be19032c7a9826054feb99eefba64c5d) Signed-off-by: Ramesh Iyyar <rameshi1@in.ibm.com> Change-Id: Ia9ed0f5a6757806080b12c97b21f1509395d1f51 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb15
1 files changed, 7 insertions, 8 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
index 7f5f9e85d..e99078db6 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
@@ -20,8 +20,7 @@ DBUS_PACKAGES = "${PN}-manager"
SYSTEMD_PACKAGES = "${PN}-monitor"
-inherit autotools \
- pkgconfig \
+inherit meson \
obmc-phosphor-dbus-service \
python3native \
phosphor-debug-collector
@@ -70,9 +69,9 @@ FILES_${PN}-scripts += "${dreport_dir}"
DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
-EXTRA_OECONF = " \
- BMC_DUMP_PATH=${bmc_dump_path} \
- ERROR_MAP_YAML=${STAGING_DIR_NATIVE}/${datadir}/dump/errors_watch.yaml \
+EXTRA_OEMESON = " \
+ -DBMC_DUMP_PATH=${bmc_dump_path} \
+ -DERROR_MAP_YAML=${STAGING_DIR_NATIVE}/${datadir}/dump/errors_watch.yaml \
"
S = "${WORKDIR}/git"
@@ -178,12 +177,12 @@ python install_dreport_user_scripts() {
#Enable ubifs-workaround by DISTRO_FEATURE obmc-ubi-fs.
PACKAGECONFIG_append_df-obmc-ubi-fs = " ubifs-workaround"
PACKAGECONFIG[ubifs-workaround] = " \
- --enable-ubifs-workaround, \
- --disable-ubifs-workaround \
+ -Dubifs-workaround=enabled, \
+ -Dubifs-workaround=disabled \
"
PACKAGECONFIG[host-dump-offload-pldm] = " \
- --with-host-dump-offload-transport=pldm,, \
+ -Dhost-dump-offload-transport=pldm,, \
pldm \
"