summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:16:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commit12fc939cde971ea2094201e48fe095c41138f4aa (patch)
tree2fc49b7224d97fc0e43011cc3d9c85eaa933d0a9 /meta-phosphor/recipes-phosphor/dump
parent9b3d987c3c2facf75e1039766d31fbf31508fc19 (diff)
downloadopenbmc-12fc939cde971ea2094201e48fe095c41138f4aa.tar.xz
meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb26
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb2
3 files changed, 15 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb b/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
index dd28e0f95..fbb41f211 100644
--- a/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
@@ -31,4 +31,4 @@ PACKAGECONFIG[triggers] = " \
-Dtriggers=[], \
systemd udev"
-SYSTEMD_SERVICE_${PN} += "debug-trigger@.service"
+SYSTEMD_SERVICE:${PN} += "debug-trigger@.service"
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
index 41b2370e3..2b7372a22 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
@@ -14,7 +14,7 @@ DEBUG_COLLECTOR_PKGS = " \
${PN}-scripts \
"
PACKAGE_BEFORE_PN += "${DEBUG_COLLECTOR_PKGS}"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
DBUS_PACKAGES = "${PN}-manager"
@@ -41,16 +41,16 @@ DEPENDS += " \
fmt \
"
-RDEPENDS_${PN}-manager += " \
+RDEPENDS:${PN}-manager += " \
${PN}-dreport \
"
-RDEPENDS_${PN}-dreport += " \
+RDEPENDS:${PN}-dreport += " \
systemd \
${VIRTUAL-RUNTIME_base-utils} \
bash \
xz \
"
-RDEPENDS_${PN}-scripts += " \
+RDEPENDS:${PN}-scripts += " \
bash \
"
@@ -58,19 +58,19 @@ MGR_SVC ?= "xyz.openbmc_project.Dump.Manager.service"
SYSTEMD_SUBSTITUTIONS += "BMC_DUMP_PATH:${bmc_dump_path}:${MGR_SVC}"
-FILES_${PN}-manager += " \
+FILES:${PN}-manager += " \
${bindir}/phosphor-dump-manager \
${exec_prefix}/lib/tmpfiles.d/coretemp.conf \
${datadir}/dump/ \
"
-FILES_${PN}-monitor += "${bindir}/phosphor-dump-monitor"
-FILES_${PN}-monitor += "${bindir}/phosphor-ramoops-monitor"
-FILES_${PN}-dreport += "${bindir}/dreport"
-FILES_${PN}-scripts += "${dreport_dir}"
+FILES:${PN}-monitor += "${bindir}/phosphor-dump-monitor"
+FILES:${PN}-monitor += "${bindir}/phosphor-ramoops-monitor"
+FILES:${PN}-dreport += "${bindir}/dreport"
+FILES:${PN}-scripts += "${dreport_dir}"
-DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
-SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
-SYSTEMD_SERVICE_${PN}-monitor += "ramoops-monitor.service"
+DBUS_SERVICE:${PN}-manager += "${MGR_SVC}"
+SYSTEMD_SERVICE:${PN}-monitor += "obmc-dump-monitor.service"
+SYSTEMD_SERVICE:${PN}-monitor += "ramoops-monitor.service"
EXTRA_OEMESON = " \
-DBMC_DUMP_PATH=${bmc_dump_path} \
@@ -80,7 +80,7 @@ EXTRA_OEMESON = " \
S = "${WORKDIR}/git"
SRC_URI += "file://coretemp.conf"
-do_install_append() {
+do_install:append() {
install -d ${D}${exec_prefix}/lib/tmpfiles.d
install -m 644 ${WORKDIR}/coretemp.conf ${D}${exec_prefix}/lib/tmpfiles.d/
}
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
index 0a232c8fa..ea2420363 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
@@ -11,7 +11,7 @@ PROVIDES += "virtual/phosphor-debug-errors"
S = "${WORKDIR}"
-do_install_append() {
+do_install:append() {
DEST=${D}${datadir}/dump
install -d ${DEST}
install errors_watch.yaml ${DEST}/