summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-10-04 22:42:48 +0300
committerGitHub <noreply@github.com>2021-10-04 22:42:48 +0300
commit0c9e31989c615598b5d042ffab385606660c93c0 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-phosphor/recipes-phosphor/dump
parent04cd92067d2481643df5010cb39b2134b648cf4d (diff)
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
downloadopenbmc-0c9e31989c615598b5d042ffab385606660c93c0.tar.xz
Merge pull request #72 from Intel-BMC/update2021-0.751-0.75
Update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb26
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb2
4 files changed, 16 insertions, 16 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb b/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
index dd28e0f95..fbb41f211 100644
--- a/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/debug-trigger_git.bb
@@ -31,4 +31,4 @@ PACKAGECONFIG[triggers] = " \
-Dtriggers=[], \
systemd udev"
-SYSTEMD_SERVICE_${PN} += "debug-trigger@.service"
+SYSTEMD_SERVICE:${PN} += "debug-trigger@.service"
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc
index 5c30040bf..812bc7ac7 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-debug-collector"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-debug-collector"
-SRCREV = "0eadeb7e78ea549da1c40016c9dc43f52df8b70d"
+SRCREV = "52ac69c15277bb3210647017403e7e4eb793e93c"
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
index 41b2370e3..2b7372a22 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
@@ -14,7 +14,7 @@ DEBUG_COLLECTOR_PKGS = " \
${PN}-scripts \
"
PACKAGE_BEFORE_PN += "${DEBUG_COLLECTOR_PKGS}"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
DBUS_PACKAGES = "${PN}-manager"
@@ -41,16 +41,16 @@ DEPENDS += " \
fmt \
"
-RDEPENDS_${PN}-manager += " \
+RDEPENDS:${PN}-manager += " \
${PN}-dreport \
"
-RDEPENDS_${PN}-dreport += " \
+RDEPENDS:${PN}-dreport += " \
systemd \
${VIRTUAL-RUNTIME_base-utils} \
bash \
xz \
"
-RDEPENDS_${PN}-scripts += " \
+RDEPENDS:${PN}-scripts += " \
bash \
"
@@ -58,19 +58,19 @@ MGR_SVC ?= "xyz.openbmc_project.Dump.Manager.service"
SYSTEMD_SUBSTITUTIONS += "BMC_DUMP_PATH:${bmc_dump_path}:${MGR_SVC}"
-FILES_${PN}-manager += " \
+FILES:${PN}-manager += " \
${bindir}/phosphor-dump-manager \
${exec_prefix}/lib/tmpfiles.d/coretemp.conf \
${datadir}/dump/ \
"
-FILES_${PN}-monitor += "${bindir}/phosphor-dump-monitor"
-FILES_${PN}-monitor += "${bindir}/phosphor-ramoops-monitor"
-FILES_${PN}-dreport += "${bindir}/dreport"
-FILES_${PN}-scripts += "${dreport_dir}"
+FILES:${PN}-monitor += "${bindir}/phosphor-dump-monitor"
+FILES:${PN}-monitor += "${bindir}/phosphor-ramoops-monitor"
+FILES:${PN}-dreport += "${bindir}/dreport"
+FILES:${PN}-scripts += "${dreport_dir}"
-DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
-SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
-SYSTEMD_SERVICE_${PN}-monitor += "ramoops-monitor.service"
+DBUS_SERVICE:${PN}-manager += "${MGR_SVC}"
+SYSTEMD_SERVICE:${PN}-monitor += "obmc-dump-monitor.service"
+SYSTEMD_SERVICE:${PN}-monitor += "ramoops-monitor.service"
EXTRA_OEMESON = " \
-DBMC_DUMP_PATH=${bmc_dump_path} \
@@ -80,7 +80,7 @@ EXTRA_OEMESON = " \
S = "${WORKDIR}/git"
SRC_URI += "file://coretemp.conf"
-do_install_append() {
+do_install:append() {
install -d ${D}${exec_prefix}/lib/tmpfiles.d
install -m 644 ${WORKDIR}/coretemp.conf ${D}${exec_prefix}/lib/tmpfiles.d/
}
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
index 0a232c8fa..ea2420363 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-errors-native.bb
@@ -11,7 +11,7 @@ PROVIDES += "virtual/phosphor-debug-errors"
S = "${WORKDIR}"
-do_install_append() {
+do_install:append() {
DEST=${D}${datadir}/dump
install -d ${DEST}
install errors_watch.yaml ${DEST}/