summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-09-29 19:19:22 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-02 20:29:35 +0300
commitffad0483a2d4715213c4ba1b58c728f1e9214ad5 (patch)
tree7c35c1dbd8cc01ef024d22a5fa7c9a35df0b2111 /meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
parent90c6342d8d44076f4e8f290fa3a43702afed164d (diff)
downloadopenbmc-ffad0483a2d4715213c4ba1b58c728f1e9214ad5.tar.xz
meta-phosphor: set phosphor-pid-control as git recipe
Renamed the phosphor-pid-control.bb to phosphor-pid-control_git.bb. This recipe is new enough that such a change should have a minimal impact. (From meta-phosphor rev: c311dec6f8d1b7529b431954b691cdc47e090b22) Change-Id: I0e4c5c3188eaa8d02a968676ca29bb192f0bc1d9 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
new file mode 100644
index 000000000..f7bc7b7cc
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -0,0 +1,51 @@
+SUMMARY = "Phosphor PID Fan Control"
+DESCRIPTION = "Fan Control"
+HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit pythonnative
+
+inherit phosphor-pid-control
+inherit obmc-phosphor-ipmiprovider-symlink
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
+SRCREV = "ce15e02f6859df404cc9c1e39b40496f3e7a15f6"
+
+# Each platform will need a service file that starts
+# at an appropriate time per system. For instance, if
+# your system relies on passive dbus for fans or other
+# sensors then it may be prudent to wait for all of them.
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "python-pyyaml-native"
+DEPENDS += "python-mako-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-logging"
+DEPENDS += "libevdev"
+DEPENDS += "libconfig"
+
+# We depend on someone providing their system's configuration.
+DEPENDS += "virtual/phosphor-fans-sensor-inventory"
+# We depend on this to be built first so we can build our providers.
+DEPENDS += "phosphor-ipmi-host"
+
+RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+
+FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor"
+
+# The following installs the OEM IPMI handler for the fan controls.
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+EXTRA_OECONF = "SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor-list.yaml \
+ PID_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/pid-list.yaml \
+ ZONE_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/zone-info.yaml"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"