summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:16:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commit12fc939cde971ea2094201e48fe095c41138f4aa (patch)
tree2fc49b7224d97fc0e43011cc3d9c85eaa933d0a9 /meta-phosphor/recipes-phosphor/fans
parent9b3d987c3c2facf75e1039766d31fbf31508fc19 (diff)
downloadopenbmc-12fc939cde971ea2094201e48fe095c41138f4aa.tar.xz
meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb4
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config.bb4
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb22
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb12
11 files changed, 28 insertions, 28 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb b/meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb
index e7d86e4c2..a138f7a37 100644
--- a/meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/obmc-control-fan_git.bb
@@ -11,5 +11,5 @@ DEPENDS = "systemd"
SKELETON_DIR = "fanctl"
-DBUS_SERVICE_${PN} += "org.openbmc.control.Fans.service"
-SYSTEMD_SERVICE_${PN} += "obmc-max-fans.service"
+DBUS_SERVICE:${PN} += "org.openbmc.control.Fans.service"
+SYSTEMD_SERVICE:${PN} += "obmc-max-fans.service"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config.bb
index 433ac65c2..7d9fbde75 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-events-config.bb
@@ -14,4 +14,4 @@ do_install() {
install -D events.yaml ${D}${control_datadir}/events.yaml
}
-FILES_${PN} += "${control_datadir}/events.yaml"
+FILES:${PN} += "${control_datadir}/events.yaml"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw.bb
index 38a424b69..428c21245 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw.bb
@@ -21,4 +21,4 @@ do_install() {
install -D fans.yaml ${D}${control_datadir}/fans.yaml
}
-FILES_${PN} += "${control_datadir}/fans.yaml"
+FILES:${PN} += "${control_datadir}/fans.yaml"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config.bb
index ae3b80ca3..54e6045bf 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config.bb
@@ -15,4 +15,4 @@ do_install() {
install -D fans.yaml ${D}${control_datadir}/fans.yaml
}
-FILES_${PN} += "${control_datadir}/fans.yaml"
+FILES:${PN} += "${control_datadir}/fans.yaml"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bb
index 319175343..8d040e1cc 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bb
@@ -14,4 +14,4 @@ do_install() {
install -D zone_conditions.yaml ${D}${control_datadir}/zone_conditions.yaml
}
-FILES_${PN} += "${control_datadir}/zone_conditions.yaml"
+FILES:${PN} += "${control_datadir}/zone_conditions.yaml"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config.bb
index 3e47d92d4..e2136f70e 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-zone-config.bb
@@ -14,4 +14,4 @@ do_install() {
install -D zones.yaml ${D}${control_datadir}/zones.yaml
}
-FILES_${PN} += "${control_datadir}/zones.yaml"
+FILES:${PN} += "${control_datadir}/zones.yaml"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config.bb
index 98604dee6..d49bda495 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-monitor-config.bb
@@ -15,4 +15,4 @@ do_install() {
install -D monitor.yaml ${D}${monitor_datadir}/monitor.yaml
}
-FILES_${PN} += "${monitor_datadir}/monitor.yaml"
+FILES:${PN} += "${monitor_datadir}/monitor.yaml"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config.bb
index 938509cd5..d2df636d4 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-config.bb
@@ -1,7 +1,7 @@
# Provides the config file for the phosphor-fan-presence application.
# The default config file is empty. To provide a real one,
# append this recipe in a layer, add:
-# FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+# FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
# and provide a config file.
SUMMARY = "Config file for phosphor-fan-presence"
@@ -21,4 +21,4 @@ do_install() {
install -D config.yaml ${D}${presence_datadir}/config.yaml
}
-FILES_${PN} += "${presence_datadir}/config.yaml"
+FILES:${PN} += "${presence_datadir}/config.yaml"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb
index 31b765463..aa0e80798 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-presence-mrw.bb
@@ -9,7 +9,7 @@ inherit mrw-xml
DEPENDS = "mrw-native mrw-perl-tools-native"
PROVIDES += "virtual/phosphor-fan-presence-config"
-FILES_${PN} += "${presence_datadir}/config.yaml"
+FILES:${PN} += "${presence_datadir}/config.yaml"
S = "${WORKDIR}"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
index 708fe4d22..7c72b6513 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
@@ -31,7 +31,7 @@ FAN_PACKAGES = " \
${PN}-monitor \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
PACKAGE_BEFORE_PN += "${FAN_PACKAGES}"
PACKAGECONFIG ?= "presence control monitor"
SYSTEMD_PACKAGES = "${FAN_PACKAGES}"
@@ -56,8 +56,8 @@ POWERON_TGT = "obmc-chassis-poweron@{0}.target"
FMT_TACH = "../${TMPL_TACH}:${POWERON_TGT}.requires/${INSTFMT_TACH}"
FMT_TACH_MUSR = "../${TMPL_TACH}:${MULTI_USR_TGT}.wants/${INSTFMT_TACH}"
-FILES_${PN}-presence-tach = "${bindir}/phosphor-fan-presence-tach"
-SYSTEMD_SERVICE_${PN}-presence-tach += "${TMPL_TACH}"
+FILES:${PN}-presence-tach = "${bindir}/phosphor-fan-presence-tach"
+SYSTEMD_SERVICE:${PN}-presence-tach += "${TMPL_TACH}"
SYSTEMD_LINK_${PN}-presence-tach += "${@compose_list(d, 'FMT_TACH', 'OBMC_CHASSIS_INSTANCES')}"
# JSON mode also gets linked into multi-user
@@ -91,9 +91,9 @@ TMPL_CONTROL_INIT = "phosphor-fan-control-init@.service"
INSTFMT_CONTROL_INIT = "phosphor-fan-control-init@{0}.service"
FMT_CONTROL_INIT = "../${TMPL_CONTROL_INIT}:${POWERON_TGT}.wants/${INSTFMT_CONTROL_INIT}"
-FILES_${PN}-control = "${bindir}/phosphor-fan-control"
-SYSTEMD_SERVICE_${PN}-control += "${TMPL_CONTROL}"
-SYSTEMD_SERVICE_${PN}-control += "${@bb.utils.contains('PACKAGECONFIG', 'json', '', '${TMPL_CONTROL_INIT}', d)}"
+FILES:${PN}-control = "${bindir}/phosphor-fan-control"
+SYSTEMD_SERVICE:${PN}-control += "${TMPL_CONTROL}"
+SYSTEMD_SERVICE:${PN}-control += "${@bb.utils.contains('PACKAGECONFIG', 'json', '', '${TMPL_CONTROL_INIT}', d)}"
# JSON: Linked to multi-user and poweron
# YAML: Linked to fans-ready and fan control-init poweron
@@ -123,9 +123,9 @@ TMPL_MONITOR_INIT = "phosphor-fan-monitor-init@.service"
INSTFMT_MONITOR_INIT = "phosphor-fan-monitor-init@{0}.service"
FMT_MONITOR_INIT = "../${TMPL_MONITOR_INIT}:${POWERON_TGT}.wants/${INSTFMT_MONITOR_INIT}"
-FILES_${PN}-monitor = "${bindir}/phosphor-fan-monitor"
-SYSTEMD_SERVICE_${PN}-monitor += "${TMPL_MONITOR}"
-SYSTEMD_SERVICE_${PN}-monitor += "${@bb.utils.contains('PACKAGECONFIG', 'json', '', '${TMPL_MONITOR_INIT}', d)}"
+FILES:${PN}-monitor = "${bindir}/phosphor-fan-monitor"
+SYSTEMD_SERVICE:${PN}-monitor += "${TMPL_MONITOR}"
+SYSTEMD_SERVICE:${PN}-monitor += "${@bb.utils.contains('PACKAGECONFIG', 'json', '', '${TMPL_MONITOR_INIT}', d)}"
# JSON: power on and multi-user links. YAML: fans-ready and fan monitor init links
SYSTEMD_LINK_${PN}-monitor += "${@bb.utils.contains('PACKAGECONFIG', 'json', \
@@ -144,6 +144,6 @@ PACKAGECONFIG[cooling-type] = "--enable-cooling-type,--disable-cooling-type,,"
# ${PN}-sensor-monitor specific configuration
PACKAGECONFIG[sensor-monitor] = "--enable-sensor-monitor, --disable-sensor-monitor"
-FILES_sensor-monitor += " ${bindir}/sensor-monitor"
-SYSTEMD_SERVICE_sensor-monitor += "sensor-monitor.service"
+FILES:sensor-monitor += " ${bindir}/sensor-monitor"
+SYSTEMD_SERVICE:sensor-monitor += "sensor-monitor.service"
SYSTEMD_LINK_sensor-monitor += "../sensor-monitor.service:${MULTI_USR_TGT}.wants/sensor-monitor.service"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
index 719538ebd..ec0bcb484 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -34,20 +34,20 @@ DEPENDS += "phosphor-ipmi-host"
SERVICE_FILE = "phosphor-pid-control.service"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}"
+SYSTEMD_SERVICE:${PN} = "${SERVICE_FILE}"
EXTRA_OECONF = " \
SYSTEMD_TARGET="multi-user.target" \
--disable-tests \
"
-FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor"
+FILES:${PN} = "${bindir}/swampd ${bindir}/setsensor"
# The following installs the OEM IPMI handler for the fan controls.
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"