summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/flash/obmc-flash-bios_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-10 06:14:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-16 05:14:21 +0300
commit8cb421de85c5ef9b6d11f3d539c68246c7feb95a (patch)
tree863e43a645417c0d8c1394d73d2bde4bd8871f76 /meta-phosphor/recipes-phosphor/flash/obmc-flash-bios_git.bb
parentd78d133afb911f4257ca51baecd83f9623f9d50d (diff)
downloadopenbmc-8cb421de85c5ef9b6d11f3d539c68246c7feb95a.tar.xz
meta-phosphor: flash: obmc-flash-bios: rename as git
obmc-flash-bios.bb inherits skeleton-gdbus, which is git-based. (From meta-phosphor rev: 67e5400e6813ba67613cc231527c4540c4fbaa47) Change-Id: I2ffd757d0db59deb29955c127f4c389e1a2bd763 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/flash/obmc-flash-bios_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/flash/obmc-flash-bios_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/flash/obmc-flash-bios_git.bb b/meta-phosphor/recipes-phosphor/flash/obmc-flash-bios_git.bb
new file mode 100644
index 000000000..8ecc04237
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/flash/obmc-flash-bios_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "OpenBMC org.openbmc.Flash example implementation"
+DESCRIPTION = "A sample implementation for the org.openbmc.Flash DBUS API. \
+org.openbmc.Flash provides APIs for functions like BIOS flash access control \
+and updating."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+SKELETON_DIR = "flashbios"
+DBUS_SERVICE_${PN} += "org.openbmc.control.Flash.service"
+SYSTEMD_SERVICE_${PN} += "obmc-flash-init.service"