summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/flash
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 00:15:49 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 00:15:49 +0300
commitf24c1e9afc47a421831278b57377951e71494d92 (patch)
treef01c5b14beb4bf31905f769569ed647884491cea /meta-phosphor/recipes-phosphor/flash
parent057594a8bb8d062d72244196170c2d78947d318a (diff)
parent31e5d79893f21786cb0635ab3640d50ff6202f6a (diff)
downloadopenbmc-f24c1e9afc47a421831278b57377951e71494d92.tar.xz
Merge tag 'wht-0.66' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/flash')
-rw-r--r--meta-phosphor/recipes-phosphor/flash/files/obmc-phosphor-flashd.py29
-rw-r--r--meta-phosphor/recipes-phosphor/flash/files/obmc-phosphor-flashd.service10
-rw-r--r--meta-phosphor/recipes-phosphor/flash/noverify-bmc-update.bb19
-rw-r--r--meta-phosphor/recipes-phosphor/flash/noverify-bmc-update/config-bmc.json20
-rw-r--r--meta-phosphor/recipes-phosphor/flash/noverify-bmc-update/noverify-bmc-verify.service6
-rw-r--r--meta-phosphor/recipes-phosphor/flash/obmc-phosphor-flashd.bb13
-rw-r--r--meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb3
8 files changed, 49 insertions, 53 deletions
diff --git a/meta-phosphor/recipes-phosphor/flash/files/obmc-phosphor-flashd.py b/meta-phosphor/recipes-phosphor/flash/files/obmc-phosphor-flashd.py
deleted file mode 100644
index 5e5dd8f36..000000000
--- a/meta-phosphor/recipes-phosphor/flash/files/obmc-phosphor-flashd.py
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/env python
-
-# Contributors Listed Below - COPYRIGHT 2015
-# [+] International Business Machines Corp.
-#
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
-# implied. See the License for the specific language governing
-# permissions and limitations under the License.
-
-import time
-import sys
-import dbus
-import dbus.service
-import dbus.mainloop.glib
-
-if __name__ == '__main__':
- print "obmc-phosphor-flashd starting..."
-
- while 1:
- time.sleep(5)
diff --git a/meta-phosphor/recipes-phosphor/flash/files/obmc-phosphor-flashd.service b/meta-phosphor/recipes-phosphor/flash/files/obmc-phosphor-flashd.service
deleted file mode 100644
index 26959196e..000000000
--- a/meta-phosphor/recipes-phosphor/flash/files/obmc-phosphor-flashd.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Phosphor Flash Controller
-
-[Service]
-Restart=always
-ExecStart=/usr/bin/env obmc-phosphor-flashd
-SyslogIdentifier=obmc-phosphor-flashd
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update.bb b/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update.bb
new file mode 100644
index 000000000..fb1480fb1
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "phosphor-ipmi-flash config to update without verifying the image"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd
+
+SRC_URI += "file://noverify-bmc-verify.service"
+SRC_URI += "file://config-bmc.json"
+
+SYSTEMD_SERVICE_${PN} += "noverify-bmc-verify.service"
+FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
+
+do_install() {
+ install -d ${D}${datadir}/phosphor-ipmi-flash
+ install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/noverify-bmc-verify.service ${D}${systemd_system_unitdir}
+}
diff --git a/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update/config-bmc.json b/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update/config-bmc.json
new file mode 100644
index 000000000..86afb3ba3
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update/config-bmc.json
@@ -0,0 +1,20 @@
+[{
+ "blob": "/flash/image",
+ "handler": {
+ "type": "file",
+ "path": "/run/initramfs/bmc-image"
+ },
+ "actions": {
+ "preparation": {
+ "type": "skip"
+ },
+ "verification": {
+ "type": "systemd",
+ "unit": "noverify-bmc-verify.service"
+ },
+ "update": {
+ "type": "systemd",
+ "unit": "reboot.target"
+ }
+ }
+}]
diff --git a/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update/noverify-bmc-verify.service b/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update/noverify-bmc-verify.service
new file mode 100644
index 000000000..50855b6b2
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/flash/noverify-bmc-update/noverify-bmc-verify.service
@@ -0,0 +1,6 @@
+[Unit]
+Description=Don't verify the image, just stage it for update
+
+[Service]
+Type=oneshot
+ExecStart=/bin/mv /run/initramfs/bmc-image /run/initramfs/image-bmc
diff --git a/meta-phosphor/recipes-phosphor/flash/obmc-phosphor-flashd.bb b/meta-phosphor/recipes-phosphor/flash/obmc-phosphor-flashd.bb
deleted file mode 100644
index 92871502f..000000000
--- a/meta-phosphor/recipes-phosphor/flash/obmc-phosphor-flashd.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-SUMMARY = "Phosphor OpenBMC Flash Management"
-DESCRIPTION = "Phosphor OpenBMC flash management reference implementation."
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit obmc-phosphor-pydbus-service
-
-PROVIDES += "virtual/obmc-flash-mgmt"
-RPROVIDES_${PN} += "virtual-obmc-flash-mgmt"
-
-S = "${WORKDIR}"
-SRC_URI += "file://${BPN}.py"
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc
index fd7fc206e..8bc566ff4 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-bmc-code-mgmt"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-bmc-code-mgmt"
-SRCREV = "1bb6dcb4a1ea8dca818d17fec834aa9e2482c4b4"
+SRCREV = "0d7198f4eb6d36968e854b3246e6568305fdcc7b"
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
index 301e4e788..d83945ea4 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
@@ -72,7 +72,10 @@ DBUS_SERVICE_${PN}-updater += "xyz.openbmc_project.Software.BMC.Updater.service"
DBUS_SERVICE_${PN}-sync += "xyz.openbmc_project.Software.Sync.service"
SYSTEMD_SERVICE_${PN}-updater += " \
+ force-reboot.service \
obmc-flash-bmc-setenv@.service \
+ reboot-guard-disable.service \
+ reboot-guard-enable.service \
usr-local.mount \
"