summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb53
1 files changed, 52 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
index eb82b3845..63908a145 100644
--- a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-image.bb
@@ -1,6 +1,57 @@
-DESCRIPTION = "Image with Phosphor, an OpenBMC framework."
+DESCRIPTION = "Image with Phosphor, a software stack for hardware management \
+in devices with baseboard management controllers. The image supports the \
+full OpenBMC feature set for devices of all types."
IMAGE_LINGUAS = ""
+IMAGE_FEATURES += " \
+ obmc-bmc-state-mgmt \
+ obmc-bmcweb \
+ obmc-chassis-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-console \
+ obmc-dbus-monitor \
+ obmc-devtools \
+ obmc-fan-control \
+ obmc-fan-mgmt \
+ obmc-flash-mgmt \
+ obmc-fru-ipmi \
+ obmc-health-monitor \
+ obmc-host-ctl \
+ obmc-host-ipmi \
+ obmc-host-state-mgmt \
+ obmc-ikvm \
+ obmc-inventory \
+ obmc-leds \
+ obmc-logging-mgmt \
+ obmc-remote-logging-mgmt \
+ obmc-rng \
+ obmc-net-ipmi \
+ obmc-sensors \
+ obmc-software \
+ obmc-system-mgmt \
+ obmc-user-mgmt \
+ obmc-user-mgmt-ldap \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', 'read-only-rootfs', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'phosphor-mmc', 'read-only-rootfs', '', d)} \
+ ssh-server-dropbear \
+ obmc-debug-collector \
+ obmc-network-mgmt \
+ obmc-settings-mgmt \
+ "
+
+LICENSE = "Apache-2.0"
+
inherit obmc-phosphor-image
+# The /etc/version file is misleading and not useful. Remove it.
+# Users should instead rely on /etc/os-release.
+ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; "
+
+# Disable the pager to prevent systemd injecting control characters into the
+# output stream that are not interpreted by busybox tools.
+ROOTFS_POSTPROCESS_COMMAND += "disable_systemd_pager ; "
+
+# The shadow recipe provides the binaries(like useradd, usermod) needed by the
+# phosphor-user-manager.
+ROOTFS_RO_UNNEEDED_remove = "shadow"