summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2020-06-04 00:22:42 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-15 00:27:57 +0300
commit0998d1e4fc58e668ccf2ea5e07b86317b066160d (patch)
tree1e05075a6acf802c3dedcce2988dcd1255de23b8 /meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
parent56e14d9ed010fd5e87a83522a3eee8bd5cd30ccc (diff)
downloadopenbmc-0998d1e4fc58e668ccf2ea5e07b86317b066160d.tar.xz
initramfs: Add init script for eMMC
This init script mounts the rootfs based on the root u-boot env variable, mounts the read-write filesystem and sets up the overlay. (From meta-phosphor rev: 86164b2e072cc6cebc9caf1614e2b1fa0e0884a0) Change-Id: If9121048b6223d5391e5f6a8b7d6cd7d22707969 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb b/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
new file mode 100644
index 000000000..45ae452c7
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/initrdscripts/phosphor-mmc-init.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Phosphor OpenBMC pre-init scripts for mmc"
+DESCRIPTION = "Phosphor OpenBMC filesystem mount implementation for mmc."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+PR = "r1"
+
+inherit allarch
+
+RDEPENDS_${PN} += " \
+ ${VIRTUAL-RUNTIME_base-utils} \
+ gptfdisk \
+ parted \
+ udev \
+"
+
+S = "${WORKDIR}"
+SRC_URI += "file://mmc-init.sh"
+
+do_install() {
+ install -m 0755 ${WORKDIR}/mmc-init.sh ${D}/init
+ install -d ${D}/dev
+ mknod -m 622 ${D}/dev/console c 5 1
+}
+
+FILES_${PN} += " /init /dev "