summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/interfaces/phosphor-rest_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-03 23:18:43 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-09 05:51:18 +0300
commitc5bbd4102e4a050990518109c48efe843a7b7b2c (patch)
treed25cd840d91bdc8811c8adb5da72f91196a39499 /meta-phosphor/recipes-phosphor/interfaces/phosphor-rest_git.bb
parent830189745ddb4922ef7c75ac645aa3e6c36e2e8c (diff)
downloadopenbmc-c5bbd4102e4a050990518109c48efe843a7b7b2c.tar.xz
meta-phosphor: rest: rename as git
Rename phosphor-rest.bb to phosphor-rest_git.bb per OE norms. This receives its SRCREV from phosphor-rest.inc. (From meta-phosphor rev: dc10ea79289c05a5e1a78391745a49fafef8f6e2) Change-Id: I29774471f07293d01b480e025038db57f60af037 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/interfaces/phosphor-rest_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/phosphor-rest_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/interfaces/phosphor-rest_git.bb b/meta-phosphor/recipes-phosphor/interfaces/phosphor-rest_git.bb
new file mode 100644
index 000000000..1331e4a24
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/interfaces/phosphor-rest_git.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Phosphor DBUS to REST WSGI Application"
+DESCRIPTION = "Phosphor DBUS to REST WSGI Application."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit allarch
+inherit obmc-phosphor-systemd
+inherit setuptools
+inherit obmc-phosphor-discovery-service
+
+require phosphor-rest.inc
+
+RRECOMMENDS_${PN} += " \
+ virtual-obmc-wsgihost \
+ python-gevent-websocket \
+ "
+
+RDEPENDS_${PN} += " \
+ python-xml \
+ python-dbus \
+ phosphor-mapper \
+ python-bottle \
+ python-spwd \
+ pyphosphor-utils \
+ pyphosphor-dbus \
+ pyphosphor-wsgi-apps-ns \
+ pamela \
+ jsnbd \
+ "
+SRC_URI += "file://url_config.json \
+ "
+
+FILES_${PN}_append = " ${datadir}/rest-dbus/url_config.json"
+
+S = "${WORKDIR}/git/module"
+SYSTEMD_SERVICE_${PN} = ""
+SYSTEMD_OVERRIDE_${PN} += "rest-dbus.conf:obmc-mapper.target.d/rest-dbus.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/wsgi_app"
+REGISTERED_SERVICES_${PN} += "phosphor_rest:tcp:443"
+
+do_install_append(){
+ install -d ${D}${datadir}/rest-dbus
+ install -m 0644 -D ${WORKDIR}/url_config.json \
+ ${D}${datadir}/rest-dbus/url_config.json
+}