summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/inventory
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-23 02:21:40 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-29 01:36:40 +0300
commitbd44fa88f1ac55161f9c26b8091f69e4229cc00c (patch)
treec07d4828c6eed6967f87f65c39f7c1dcec8d539f /meta-phosphor/recipes-phosphor/inventory
parent5e2c8c7e4178ac45d3b44ce2bc541e9a1e0d8a76 (diff)
downloadopenbmc-bd44fa88f1ac55161f9c26b8091f69e4229cc00c.tar.xz
meta-phosphor: inventory: enable non-native recipes
There exists a number native class recipes throughout meta-phosphor that simply provide a data (often YAML) file as input to building another application. Having these data file recipes implemented as native class recipes prevents the use of machine overrides because bitbake (rightfully so) discards machine qualifiers from native recipes. Further, data files aren't really any different than library header files and those are consumed by recipes as target class recipes that are DEPENDed on. Do the same thing for data file recipes. (From meta-phosphor rev: 1675a60bc9648cb5c7ec224df3791dbe89f09134) Change-Id: I7fa23c7914abc5018f6534a8daa0462c6ee9daa3 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/inventory')
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb (renamed from meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb)15
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb6
2 files changed, 9 insertions, 12 deletions
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb
index b02ea28aa..2dd6e281c 100644
--- a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag-native.bb
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager-assettag.bb
@@ -3,19 +3,16 @@ PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-inherit native
+inherit allarch
inherit phosphor-inventory-manager
PROVIDES += "virtual/phosphor-inventory-manager-assettag"
-
-SRC_URI += "file://assettag.yaml"
-
S = "${WORKDIR}"
-do_install() {
- # This recipe would provide the yaml for inventory manager to
- # create AssetTag property at startup
+SRC_URI = "file://assettag.yaml"
- install -d ${D}${base_datadir}/events.d/
- install assettag.yaml ${D}${base_datadir}/events.d/assettag.yaml
+do_install() {
+ install -D assettag.yaml ${D}${base_datadir}/events.d/assettag.yaml
}
+
+FILES_${PN} += "${base_datadir}/events.d/assettag.yaml"
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
index 1b54dd500..520cdcc99 100644
--- a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
@@ -15,7 +15,7 @@ inherit autotools \
require phosphor-inventory-manager.inc
DEPENDS += " \
- ${PN}-config-native \
+ phosphor-inventory-manager-assettag \
phosphor-dbus-interfaces \
phosphor-dbus-interfaces-native \
phosphor-logging \
@@ -33,11 +33,11 @@ DBUS_SERVICE_${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"
S = "${WORKDIR}/git"
EXTRA_OECONF = " \
- YAML_PATH=${STAGING_DIR_NATIVE}${base_datadir} \
+ YAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
IFACE=${OBMC_INVENTORY_MGR_IFACE} \
- IFACES_PATH=${STAGING_DIR_NATIVE}${yaml_dir} \
+ IFACES_PATH=${STAGING_DIR_HOST}${yaml_dir} \
"
PACKAGECONFIG ??= ""