summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
diff options
context:
space:
mode:
authorVernon Mauery <vernon.mauery@linux.intel.com>2020-03-04 22:02:02 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-18 05:44:17 +0300
commite0b32cb26dd6a4a3ab04cf913d616ce2d5e7693c (patch)
tree4889e7e42a0880571564aee30c3b76c7e18b904c /meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
parent39f5a6b43b4ed43db5bf9b8eb8179a99c8533b62 (diff)
downloadopenbmc-e0b32cb26dd6a4a3ab04cf913d616ce2d5e7693c.tar.xz
Update the ipmitool to a more recent commit
ipmitool is now under active development. This pulls in the latest commit as of now. Because of the change to a newer version of ipmitool, how it deals with the enterprise-numbers file is different. Because the makefile just wants to download the latest version (which would mean non-repeatable builds), this commit manually downloads it so it is versioned. I went through the list of companies that have CLAs with openBMC and found them in the iana list. This mostly just means that if one of the companies contributing to OpenBMC writes an OEM IPMI handler, ipmitool will be able to determine what OEM it is by name. This is not an essential thing in 99% of the cases. There won't be a need for any of the iana numbers for any of the entities that are not writing IPMI OEM providers. This adds a note to the bbappend file to update the enterprise-numbers file any time a new company joins the OpenBMC project by submitting a CLA, assuming that they have a number on file with the IANA. Tested: builds as expected. runs as expected from bmc console. (From meta-phosphor rev: 0b4708bff38a85eb706f4ab4894c0aa584877633) Change-Id: Id2cd25d693894805b79f8bd589246a135bd1490d Signed-off-by: Vernon Mauery <vernon.mauery@linux.intel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend22
1 files changed, 19 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
index d52f33038..8f390f554 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -3,13 +3,29 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
DEPENDS += "systemd"
SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https"
-SRCREV = "d818c2ff85c011be29c8d3047e516a5e032a1923"
+SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901"
-# this patch has been submitted to ipmitool upstream and is in review
+# TODO: when a new company joins the OpenBMC project by signing
+# a CLA, if they have an enterprise number on file with the
+# IANA, the versioned file, $PWD/ipmitool/enterprise-numbers
+# needs to be updated to add their entry. The canonical
+# version of the file is locatede here:
+# https://www.iana.org/assignments/enterprise-numbers
+#
+# This file is manually downloaded so it can be versioned
+# instead of having the makefile download it during do_compile
SRC_URI += " \
- file://0001-create_pen_list-only-print-if-values-are-set.patch \
+ file://enterprise-numbers \
"
+# make sure that the enterprise-numbers file gets installed in the root FS
+FILES_${PN} += "/usr/share/misc/enterprise-numbers"
+do_compile_prepend() {
+ # copy the SRC_URI version of enterprise-numbers
+ # to the build dir to prevent a fetch
+ cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
+}
+
S = "${WORKDIR}/git"
LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"