summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
diff options
context:
space:
mode:
authorRichard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>2018-12-14 06:34:40 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-12-18 15:47:39 +0300
commit7a8e9b29c5f6d0b8153a8e226097e8bcbb0fd554 (patch)
treed2150fd2395229fb463e21104b0bbe082110fe2e /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
parent365ec7aa27c9f22f80f9c87df9d16b9b24d8e1ab (diff)
downloadopenbmc-7a8e9b29c5f6d0b8153a8e226097e8bcbb0fd554.tar.xz
Add root user to required groups as per recipe
root user has to be added to groups accordingly based on the recipe. i.e. phosphor-ipmi-host_git.bb, will create both ipmi group, and add root user to the same. Unit-test: 1. Verified root user is added to the groups accordingly. (From meta-phosphor rev: 41882fbf717f267b280ab8ed3393f1178a029258) Change-Id: I79d3a23fd939f38064999ebe99f17f3e0c02ed0c Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index f576aec9e..e85b2609c 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -56,6 +56,8 @@ inherit useradd
USERADD_PACKAGES = "${PN}"
# add ipmi group
GROUPADD_PARAM_${PN} = "ipmi"
+# Add root user to ipmi group
+GROUPMEMS_PARAM_${PN} = "-g ipmi -a root"
SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"