summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-08-19 22:32:53 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-03 01:25:50 +0300
commit8327bbaf171d15228af3480971e5ad4273c0a0a0 (patch)
tree6dd7d68b5c1647fa325d82a2323d36adec727c6f /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
parent28511e7f3b9fe029cf46c84aed15882bb6870a0f (diff)
downloadopenbmc-8327bbaf171d15228af3480971e5ad4273c0a0a0.tar.xz
meta-phosphor: ipmi-config: add default entity map
Add an empty entity map json file. The file is expected to be an array, if it is present at all. The file provided by default has no real meaning to your system, therefore you are expected if you use the entity records, to provide one for your system. See: https://github.com/openbmc/phosphor-host-ipmid/blob/master/scripts/entity-example.md for details on how it should be formatted. Currently formatted: [{ "id": 1, # Container entity contains other entities # Entity Id and entity Instance for the container entity "containerEntityId": 13, "containerEntityInstance": 81, # A record can have contained entities as a four entry list or as upto # two ranges of entity instances; this record has contained entities # as a four entry list "isList": true, # Records can be linked if necessary to extend the number of contained # entities within a container entity; this record is not linked "isLinked": false, "entities": [ {"entityId1": 10, "entityInstance1": 1}, {"entityId2": 10, "entityInstance2": 3}, {"entityId3": 10, "entityInstance3": 5}, {"entityId4": 10, "entityInstance4": 7} ] }] (From meta-phosphor rev: 34d8886d6642eb0b991b696f4d28950c5bec9bf5) Signed-off-by: Patrick Venture <venture@google.com> Change-Id: I00956c92d444ac82d4a9aabfd33c26ccbb58e145 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb12
1 files changed, 0 insertions, 12 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 1df091fe2..f654d0ce6 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -14,8 +14,6 @@ inherit obmc-phosphor-systemd
inherit phosphor-ipmi-host
inherit pythonnative
-SRC_URI += "file://entity.yaml"
-
def ipmi_whitelists(d):
whitelists = d.getVar(
'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
@@ -103,16 +101,6 @@ SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
-do_replace_entity_default() {
- # The in-repo provided default is tailored to testing the ipmid code.
- # Replace it with a reasonable default for users.
- cp ${THISDIR}/${PN}/entity.yaml ${S}/scripts/entity-example.yaml
-}
-
-do_patch_append() {
- bb.build.exec_func('do_replace_entity_default', d)
-}
-
#Collect all hardcoded sensor yamls from different recipes and
#merge all of them with sensor.yaml.
python do_merge_sensors () {