summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
diff options
context:
space:
mode:
authorTom Joseph <tomjoseph@in.ibm.com>2020-03-05 19:08:45 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-11 01:35:40 +0300
commitf4db37946fc958d1f15c03fdf6282b2a602f848c (patch)
tree30cf28190cc6e9051732617391e7cb8529d781c9 /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
parente78fb7d92586a2656bfac7537756ecb3ae970f29 (diff)
downloadopenbmc-f4db37946fc958d1f15c03fdf6282b2a602f848c.tar.xz
phosphor-host-ipmid : Fix missing python dependency
The repo runs python to generate code or validate config, which requires python and the dependent python packages. Previously that happens to be satisfied by sdbusplus's RDEPENDS. If sdbusplus is changed to use python3, this repo fails to built because it lacks of dependency. See details in https://lists.ozlabs.org/pipermail/openbmc/2020-February/020771.html This commit fixes the depends by adding the required python and python-packages so that it builds fine. (From meta-phosphor rev: 6c283fc1d3bd78e65b2113549aee5f26a4cf0977) Change-Id: Ic1ead46608510c292980b1a81176523767aec50a Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 6bd95e86f..a59e1fdd0 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -35,6 +35,9 @@ DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
DEPENDS += "boost"
DEPENDS += "sdeventplus"
+DEPENDS += "${PYTHON_PN}-native"
+DEPENDS += "${PYTHON_PN}-pyyaml-native"
+DEPENDS += "${PYTHON_PN}-mako-native"
VIRTUAL-RUNTIME_ipmi-config ?= "phosphor-ipmi-config"