summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-10 05:50:21 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-16 05:13:10 +0300
commit6c0e65cb2a0ed496bb2ea3797d5490bdea79993d (patch)
treec3eb3f11e65b8f2fa043c5c87245b2bbd3da2aeb /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb
parentec3c4cd32d08d1128f7c3cd3300cf80722f0b777 (diff)
downloadopenbmc-6c0e65cb2a0ed496bb2ea3797d5490bdea79993d.tar.xz
meta-phosphor: ipmi: phosphor-ipmi-hw-example: rename as git
phosphor-ipmi-hw-example.bb inherits skeleton-python, which is git-based. (From meta-phosphor rev: 90c8a626bd4d7f6d5489a78d777423a7e67785b5) Change-Id: I052d7f2792c97f14286eda54ad7079a9cc925ba8 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb
new file mode 100644
index 000000000..a9e070c7b
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-hw-example_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Phosphor OpenBMC host IPMI to DBUS Example"
+DESCRIPTION = "Phosphor OpenBMC host IPMI to DBUS example implementation."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+RDEPENDS_${PN} += "python-subprocess python-dbus python-pygobject"
+RRECOMMENDS_${PN} += "phosphor-ipmi-host"
+
+inherit skeleton-python
+
+PROVIDES += "virtual/obmc-host-ipmi-hw"
+RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
+
+SKELETON_DIR = "pyipmitest"