summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-kcs_git.bb
diff options
context:
space:
mode:
authorVernon Mauery <vernon.mauery@linux.intel.com>2019-03-22 22:25:14 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-20 17:02:07 +0300
commitabdf3dc1b5617e97cfca468d9a12628431183e82 (patch)
treed8dc700a3db7d2aadfa5a7017ee56461387d18a1 /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-kcs_git.bb
parenta4fddd78818c6f5fac19e42cdb9a9125e13945db (diff)
downloadopenbmc-abdf3dc1b5617e97cfca468d9a12628431183e82.tar.xz
Make phosphor-ipmi-kcs parameterized by device
The end goal is to run one ipmi bridge per interface, so that stopping that bridge will effectively shut down ipmi on that interface. By default, this enables KCS on /dev/ipmi-kcs3. If more than one KCS interface is desired, they can be added in a bbbappend as follows: phosphor-ipmi-kcs_%.bbappend: ALT_KCS_DEV = "ipmi-kcs4" SYSTEMD_SERVICE_${PN} += " \ ${PN}@${ALT_KCS_DEV}.service \ " (From meta-phosphor rev: ed16aacb16b908a1bc0c46b7dff54c13802d3aa0) Change-Id: Ib8acf989721f22abf9a95f006b12486972fd6f5a Signed-off-by: Vernon Mauery <vernon.mauery@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-kcs_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-kcs_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-kcs_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-kcs_git.bb
index f50b35443..652d83c43 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-kcs_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-kcs_git.bb
@@ -6,14 +6,14 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b1beb00e508e89da1ed2a541934f28c0"
inherit autotools pkgconfig
-inherit obmc-phosphor-dbus-service
+inherit systemd
PV = "1.0+git${SRCPV}"
KCS_DEVICE ?= "ipmi-kcs3"
-DBUS_SERVICE_${PN} = "org.openbmc.HostIpmi.service"
-SYSTEMD_SUBSTITUTIONS += "KCS_DEVICE:${KCS_DEVICE}:org.openbmc.HostIpmi.service"
+SYSTEMD_SERVICE_${PN} = " ${PN}@${KCS_DEVICE}.service "
+FILES_${PN} += " ${systemd_system_unitdir}/${PN}@.service "
PROVIDES += "virtual/obmc-host-ipmi-hw"
RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
@@ -30,7 +30,7 @@ DEPENDS += " \
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/kcsbridge.git"
-SRCREV = "9ce5a9a0ba3fc08bf8f44f0582ea6df5819c09f3"
+SRCREV = "87e8e61c83da593a1cc271ab511313b14a321bfe"
# This is how linux-libc-headers says to include custom uapi headers
CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"