summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/leds
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-08-13 23:20:46 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-17 17:49:10 +0300
commit3f248dc32aa8c8f9c294d955fe0f19d8c8c4579a (patch)
tree6d8d067b95df452b90fc5522c60a17460ff0e06d /meta-phosphor/recipes-phosphor/leds
parent4d1faa815e4dbfd5e2ef194f0214612d44e1a337 (diff)
downloadopenbmc-3f248dc32aa8c8f9c294d955fe0f19d8c8c4579a.tar.xz
led-group: move to action targets
While debugging another issue, it was noticed that this service, obmc-led-group-start/stop@power_on.service was installed within a synchronization target. Specifically within the obmc-power-stop@0.target. This target is only meant to be used as a synchronization target, where other services use Wants/After/Before type syntax to synchronize when they run. For installing a service, the standard action targets should be used, obmc-chassis-poweron@.target and obmc-chassis-poweroff@.target. Tested: - Verified services are in correct target and still run during chassis on and power off. Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I5fecc8236e20f83fb5636445710621bbc8b46b57
Diffstat (limited to 'meta-phosphor/recipes-phosphor/leds')
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
index 7e6072508..b834b6b19 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
@@ -41,12 +41,13 @@ SYSTEMD_SERVICE:${PN}-faultmonitor += "obmc-fru-fault-monitor.service"
SYSTEMD_LINK_${PN} += "../obmc-led-group-start@.service:multi-user.target.wants/obmc-led-group-start@bmc_booted.service"
+CHASSIS_TARGETS = "poweron poweroff"
STATES = "start stop"
-TMPLFMT = "obmc-led-group-{0}@.service"
-TGTFMT = "obmc-power-{0}@0.target"
-INSTFMT = "obmc-led-group-{0}@power_on.service"
+TMPLFMT = "obmc-led-group-{1}@.service"
+TGTFMT = "obmc-chassis-{0}@0.target"
+INSTFMT = "obmc-led-group-{1}@power_on.service"
FMT = "../${TMPLFMT}:${TGTFMT}.wants/${INSTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'STATES')}"
+SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'FMT', 'CHASSIS_TARGETS', 'STATES')}"
# Install the override to set up a Conflicts relation
SYSTEMD_OVERRIDE_${PN} += "bmc_booted.conf:obmc-led-group-start@bmc_booted.service.d/bmc_booted.conf"