summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/leds
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2020-03-30 15:16:17 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-01 16:35:58 +0300
commitd7844698dee6b649b4eec220236a19383ad873fb (patch)
treebc1fbe960c7c5ec27cbc14d9cd311070ee94a2c5 /meta-phosphor/recipes-phosphor/leds
parent2a242416e347fbe4a0dfc3f8fda031fa61dc805f (diff)
downloadopenbmc-d7844698dee6b649b4eec220236a19383ad873fb.tar.xz
phosphor-led-manager: Add python dependencies explicitly
Python dependencies for phosphor-led-manager is currently being satisfied by inclusion of sdbusplus in the recipe. This will break if sdbusplus changes its dependency list and hence adding python dependency here (From meta-phosphor rev: 48821f55ec14ab698b3ebcb568e30fc17ae1c8f6) Change-Id: I9b4cf14e4f9f9b6ac8296368a179678196a33298 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/leds')
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
index 8689e06c0..613603272 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
@@ -20,7 +20,9 @@ DBUS_PACKAGES = "${PN}-ledmanager"
SYSTEMD_PACKAGES = "${LED_MGR_PACKAGES}"
-DEPENDS += "python-pyyaml-native"
+DEPENDS += "${PYTHON_PN}-native"
+DEPENDS += "${PYTHON_PN}-pyyaml-native"
+DEPENDS += "${PYTHON_PN}-inflection-native"
DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbusplus sdbusplus-native"
DEPENDS += "systemd"