summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-04-30 18:27:59 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-05-03 14:41:32 +0300
commit2d52a389366be11fed6a81378b0669e2c274f220 (patch)
tree230655a123600e138a22a5e48076461491b9af29 /meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
parentcbbc4842f4be7caaa94aa586c60dd5d64075ce66 (diff)
downloadopenbmc-2d52a389366be11fed6a81378b0669e2c274f220.tar.xz
phosphor-logging: convert to meson
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I2a5eb57d100ced02043bf68f64e4596c59da6ebd
Diffstat (limited to 'meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb20
1 files changed, 7 insertions, 13 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index a5b6990fe..e714a8e26 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -7,13 +7,12 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit autotools pkgconfig
+inherit meson
inherit python3native
inherit obmc-phosphor-dbus-service
inherit phosphor-logging
inherit phosphor-dbus-yaml
-DEPENDS += "autoconf-archive-native"
DEPENDS += "systemd"
DEPENDS += "${PYTHON_PN}-mako-native"
DEPENDS += "${PYTHON_PN}-pyyaml-native"
@@ -56,21 +55,16 @@ SRCREV = "60356ad409fd51703ba2ac7ea13df3d7f0426d0c"
S = "${WORKDIR}/git"
-PACKAGECONFIG ??= "metadata-processing"
-
-PACKAGECONFIG[metadata-processing] = " \
- --enable-metadata-processing, \
- --disable-metadata-processing, , \
- "
+PACKAGECONFIG ??= ""
PACKAGECONFIG[openpower-pels] = " \
- --enable-openpower-pel-extension, \
- --disable-openpower-pel-extension, \
+ -Dopenpower-pel-extension=enabled, \
+ -Dopenpower-pel-extension=disabled, \
nlohmann-json cli11 pldm, \
python3, \
"
-EXTRA_OECONF = " \
- YAML_DIR=${STAGING_DIR_TARGET}${yaml_dir} \
- CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
+EXTRA_OEMESON = " \
+ -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
+ -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
"