summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-06-25 18:34:41 +0300
committerGitHub <noreply@github.com>2021-06-25 18:34:41 +0300
commitc6b1c6ba7a01b7987d65d61c262c44c320193108 (patch)
treec31fba338a65c86741b16e061d66e0e060e3b768 /meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
parente7436234669703196c5ed56f33050d2dc19127cd (diff)
parentdefdca82c107f46e980c84bffb1b2c1263522fa0 (diff)
downloadopenbmc-c6b1c6ba7a01b7987d65d61c262c44c320193108.tar.xz
Merge pull request #68 from Intel-BMC/update2021-0.571-0.57
Update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb25
1 files changed, 11 insertions, 14 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index 5fa7f7a03..4e47e373b 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -7,13 +7,12 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit autotools pkgconfig
+inherit meson
inherit python3native
inherit obmc-phosphor-dbus-service
inherit phosphor-logging
inherit phosphor-dbus-yaml
-DEPENDS += "autoconf-archive-native"
DEPENDS += "systemd"
DEPENDS += "${PYTHON_PN}-mako-native"
DEPENDS += "${PYTHON_PN}-pyyaml-native"
@@ -39,8 +38,11 @@ ALLOW_EMPTY_${PN} = "1"
PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
DBUS_PACKAGES = "${LOGGING_PACKAGES}"
+USERADD_PACKAGES = "${PN}-base"
+GROUPADD_PARAM_${PN}-base = "-r phosphor-logging"
FILES_${PN}-base += " \
+ ${sysconfdir}/dbus-1 \
${bindir}/phosphor-log-manager \
${libdir}/libphosphor_logging.so.* \
"
@@ -52,25 +54,20 @@ FILES_phosphor-rsyslog-config += " \
"
SRC_URI += "git://github.com/openbmc/phosphor-logging"
-SRCREV = "6b3f345b3f265036ec339d097f9d60d12998015d"
+SRCREV = "0b08776a882357d7e96ee072d14ba0940287ca93"
S = "${WORKDIR}/git"
-PACKAGECONFIG ??= "metadata-processing"
-
-PACKAGECONFIG[metadata-processing] = " \
- --enable-metadata-processing, \
- --disable-metadata-processing, , \
- "
+PACKAGECONFIG ??= ""
PACKAGECONFIG[openpower-pels] = " \
- --enable-openpower-pel-extension, \
- --disable-openpower-pel-extension, \
+ -Dopenpower-pel-extension=enabled, \
+ -Dopenpower-pel-extension=disabled, \
nlohmann-json cli11 pldm, \
python3, \
"
-EXTRA_OECONF = " \
- YAML_DIR=${STAGING_DIR_TARGET}${yaml_dir} \
- CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
+EXTRA_OEMESON = " \
+ -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
+ -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
"