summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/mctp/mctp_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-03-02 22:06:48 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-03-02 22:06:48 +0300
commit9600a7403ba2848c8751280077503a3e0f2f3481 (patch)
tree996726918f255cc9686dec34628fab410ac8f550 /meta-phosphor/recipes-phosphor/mctp/mctp_git.bb
parentb11bad1ba28f79c08266efb9cc265d89103e5939 (diff)
parent5ec7af7413906b500cce396255bde69c9770f6d8 (diff)
downloadopenbmc-9600a7403ba2848c8751280077503a3e0f2f3481.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/mctp/mctp_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/mctp/mctp_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/mctp/mctp_git.bb b/meta-phosphor/recipes-phosphor/mctp/mctp_git.bb
new file mode 100644
index 000000000..a2577cfc4
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/mctp/mctp_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "MCTP stack"
+DESCRIPTION = "MCTP library implementing the MCTP base specification"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit systemd
+inherit autotools pkgconfig
+
+HOMEPAGE = "https://github.com/openbmc/libmctp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
+SRC_URI = "git://github.com/openbmc/libmctp \
+ file://default"
+SRCREV = "34b9b3d82b049610775aea4460ff0f3bb9f02b1d"
+CONFFILES_${PN} = "${sysconfdir}/default/mctp"
+
+DEPENDS += "autoconf-archive-native \
+ systemd \
+ "
+
+SYSTEMD_SERVICE_${PN} = "mctp-demux.service"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
+}
+
+S = "${WORKDIR}/git"