summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/mrw
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-03-04 01:11:40 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-03-09 17:12:43 +0300
commitaae820c542c0bbf907fff93e3b0fc865465fad60 (patch)
treeac5567dced5f6b0a848b2a057132a680a438c4d1 /meta-phosphor/recipes-phosphor/mrw
parente0dab98ac45d06451672cb19297d3573c3bccd85 (diff)
downloadopenbmc-aae820c542c0bbf907fff93e3b0fc865465fad60.tar.xz
perl: workaround recipe bug in perl-version.bbclass
Without this change, we get this error when building a system that uses native perl: Can't locate mrw/Targets.pm in @INC The mrw-api-native.bb recipe uses the PERLVERSION variable provided by perl-version.bbclass. This class appears to require the native class be inherited prior to it in order to correctly set PERLVERSION. When it is not inherited prior, "None" appears where the perl version should be. This issue was found when OpenBMC fixed its recipe inheritance order in https://gerrit.openbmc-project.xyz/c/openbmc/openbmc/+/40974 openbmc/openbmc#3770 tracks final resolution to this issue which will most likely be working with upstream yocto. This commit is a short term solution to get openbmc building again without a full revert of 40974. Tested: - Verified witherspoon built from scratch with this change Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: Ie9f8ef7b292801736b2ba44e10d688c67eb31e32
Diffstat (limited to 'meta-phosphor/recipes-phosphor/mrw')
-rw-r--r--meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
index f6581beb1..b8c311bd1 100644
--- a/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
S = "${WORKDIR}/git"
+inherit native
inherit perlnative
inherit cpan-base
inherit mrw-rev
-inherit native
DEPENDS += "libxml-simple-perl-native json-perl-native"